aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-file-sharedir-install
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-30 07:42:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-30 07:42:53 +0000
commit6861ecf094bb7090efa45976e4f945da3faa9a43 (patch)
tree34008385dc4289119a7ca216cb409729be0c6ffa /main/perl-file-sharedir-install
parentf227eb4c61ab1cceaa050a03a19480131dd9cde9 (diff)
downloadaports-6861ecf094bb7090efa45976e4f945da3faa9a43.tar.bz2
aports-6861ecf094bb7090efa45976e4f945da3faa9a43.tar.xz
main/perl-file-sharedir-install: new aport
Install shared files http://search.cpan.org/dist/File-ShareDir-Install/
Diffstat (limited to 'main/perl-file-sharedir-install')
-rw-r--r--main/perl-file-sharedir-install/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/perl-file-sharedir-install/APKBUILD b/main/perl-file-sharedir-install/APKBUILD
new file mode 100644
index 0000000000..0093eac155
--- /dev/null
+++ b/main/perl-file-sharedir-install/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-file-sharedir-install
+_pkgreal=File-ShareDir-Install
+pkgver=0.09
+pkgrel=0
+pkgdesc="Install shared files"
+url="http://search.cpan.org/dist/File-ShareDir-Install/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GW/GWYN/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="508fd1f977f2e160e7e756c9c73868df File-ShareDir-Install-0.09.tar.gz"
+sha256sums="ed4fdbbd691726d45b78538c63eb1b08a7b0853cf07ec327256d0dd590acc0dc File-ShareDir-Install-0.09.tar.gz"
+sha512sums="11adcce3d868da71987cb03eaef34e38bb9dfc62dcec26288f088eecc039f0c5e1f6a49fa0103359ecaf57a9d4ac51a967f0968a31cfbe3db6bdfae70bcbb626 File-ShareDir-Install-0.09.tar.gz"