aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-file-sharedir-install
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-27 15:55:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-28 17:15:35 +0000
commitc9a6a2a18bbaccd13c47e77fac948b558aa8cf5d (patch)
treebc1d385a985b6dff8820f3f6ebbd008c12eebc83 /main/perl-file-sharedir-install
parent299b5ca2b5eafcc7e2e3aec340fc0f9c064e3093 (diff)
downloadaports-c9a6a2a18bbaccd13c47e77fac948b558aa8cf5d.tar.bz2
aports-c9a6a2a18bbaccd13c47e77fac948b558aa8cf5d.tar.xz
main/perl-file-sharedir-install: upgrade to 0.11 and modernize
Diffstat (limited to 'main/perl-file-sharedir-install')
-rw-r--r--main/perl-file-sharedir-install/APKBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/main/perl-file-sharedir-install/APKBUILD b/main/perl-file-sharedir-install/APKBUILD
index f27977c558..d17a1df714 100644
--- a/main/perl-file-sharedir-install/APKBUILD
+++ b/main/perl-file-sharedir-install/APKBUILD
@@ -3,39 +3,44 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-file-sharedir-install
_pkgreal=File-ShareDir-Install
-pkgver=0.10
+pkgver=0.11
pkgrel=0
pkgdesc="Install shared files"
url="http://search.cpan.org/dist/File-ShareDir-Install/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+makedepends="perl-dev $cpanmakedepends perl-module-build-tiny"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/G/GW/GWYN/$_pkgreal-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="37fb7fa72ce7184516dd022aba62f524 File-ShareDir-Install-0.10.tar.gz"
-sha256sums="708af71dec4dfb5a8cf9a5e863b566714c3f65f0a76722302de5a07ee202e6f7 File-ShareDir-Install-0.10.tar.gz"
-sha512sums="96c3a94da78e51c97223f16892c6bdb6a93f9602643aca6ee73fd661aefb0a018938f03b8265f255dc3daba467e01a2d2a924f33a5e1e4d2e9c9fe2698a3d09f File-ShareDir-Install-0.10.tar.gz"
+sha512sums="6611f6c3221ec52db7582f30b2159dba22ca8d899666526c069298b3350ced9e3b46872baaceb30f7a27e3c744c929ca4967fa820d14bbfdb41e5ed5485a9f72 File-ShareDir-Install-0.11.tar.gz"