aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-ldap
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-11 11:57:25 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-13 09:08:07 +0000
commit047f04b1830bc95fc9fc11c227b555741368512d (patch)
tree1d0dc29a349019e4ac4f3ff46d4c65f2b7a8df0b /main/perl-ldap
parent5b4fc48d93187683fc3ee4479a8a59b2065e8b79 (diff)
downloadaports-047f04b1830bc95fc9fc11c227b555741368512d.tar.bz2
aports-047f04b1830bc95fc9fc11c227b555741368512d.tar.xz
main/perl-ldap: add missing make dependency and modernize
Diffstat (limited to 'main/perl-ldap')
-rw-r--r--main/perl-ldap/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/main/perl-ldap/APKBUILD b/main/perl-ldap/APKBUILD
index 2822e5cddf..a79f8e732d 100644
--- a/main/perl-ldap/APKBUILD
+++ b/main/perl-ldap/APKBUILD
@@ -3,40 +3,43 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-ldap
pkgver=0.65
-pkgrel=0
+pkgrel=1
pkgdesc="LDAP client library"
url="http://search.cpan.org/dist/perl-ldap/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-convert-asn1"
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends perl-text-soundex"
+makedepends="perl-dev $cpanmakedepends perl-text-soundex perl-module-install"
replaces="perl-net-ldap"
provides="perl-net-ldap"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/M/MA/MARSCHAP/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="d057c8db76913d95c0e460c7bdd98b27 perl-ldap-0.65.tar.gz"
-sha256sums="5f57dd261dc16ebf942a272ddafe69526598df71151a51916edc37a4f2f23834 perl-ldap-0.65.tar.gz"
sha512sums="567de41fc1e659de23b4ae7b6cec5a60df0ad8bc90062158cf83f90d3729ac27a8bacb276b732931fefbf33847fe1baec7a62393aae5978f3c55c6c602f93747 perl-ldap-0.65.tar.gz"