aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-10-11 10:51:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-10-11 10:51:31 +0000
commit8954ee8b7f4c09b650131aac170d876a18be8a96 (patch)
tree32c423f2803f0396a7059002c85a3508debe4333 /main/perl
parent4ff0ef86f973dc8d8e6d6d49c7cdf0d9c6298e50 (diff)
downloadaports-8954ee8b7f4c09b650131aac170d876a18be8a96.tar.bz2
aports-8954ee8b7f4c09b650131aac170d876a18be8a96.tar.xz
main/perl: use system zlib
The bundled zlib 1.2.8 is vulnerable to: - CVE-2016-9843 - CVE-2016-9841 - CVE-2016-9840 - CVE-2016-9842 Force building with system zlib, and while at it, also do that with bzip2
Diffstat (limited to 'main/perl')
-rw-r--r--main/perl/APKBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/main/perl/APKBUILD b/main/perl/APKBUILD
index 7062f00973..e687152cba 100644
--- a/main/perl/APKBUILD
+++ b/main/perl/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=perl
pkgver=5.26.1
-pkgrel=0
+pkgrel=1
pkgdesc="Larry Wall's Practical Extraction and Report Language"
url="http://www.perl.org/"
arch="all"
@@ -11,7 +11,7 @@ license="Artistic GPL2"
options="!fhs"
depends=""
depends_dev="perl-utils"
-makedepends=""
+makedepends="bzip2-dev zlib-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-utils::noarch miniperl"
source="http://www.cpan.org/src/5.0/perl-$pkgver.tar.gz
"
@@ -33,10 +33,22 @@ prepare() {
sed -e 's/less -R/less/g' \
-e 's/libswanted="\(.*\) nsl\(.*\)"/libswanted="\1\2"/g' \
-i ./Configure || return 1
+
+ # Ensure that we never accidentally bundle zlib or bzip2
+ rm -rf cpan/Compress-Raw-Zlib/zlib-src
+ rm -rf cpan/Compress-Raw-Bzip2/bzip2-src
+ sed -i '/\(bzip2\|zlib\)-src/d' MANIFEST
+
}
build() {
cd "$builddir"
+ BUILD_ZLIB=0
+ BUILD_BZIP2=0
+ BZIP2_LIB=/usr/lib
+ BZIP2_INCLUDE=/usr/inculde
+
+ export BUILD_ZLIB BUILD_BZIP2 BZIP2_LIB BZIP2_INCLUDE
./Configure -des \
-Dcccdlflags='-fPIC' \
-Dcccdlflags='-fPIC' \