aboutsummaryrefslogtreecommitdiffstats
path: root/main/polkit-gnome/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-30 14:00:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-30 14:23:04 +0000
commitc95fe5e4569caa1b2acb938f7d7b2fc4ff0722d8 (patch)
tree29eecbfd945df1b78372ff42154ab63fcf138568 /main/polkit-gnome/APKBUILD
parent9bc1ea3b9db7780e8b420bfcae5656a23104c5fd (diff)
downloadaports-c95fe5e4569caa1b2acb938f7d7b2fc4ff0722d8.tar.bz2
aports-c95fe5e4569caa1b2acb938f7d7b2fc4ff0722d8.tar.xz
main/polkit-gnome: moved from testing
Diffstat (limited to 'main/polkit-gnome/APKBUILD')
-rw-r--r--main/polkit-gnome/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/main/polkit-gnome/APKBUILD b/main/polkit-gnome/APKBUILD
new file mode 100644
index 0000000000..d167653ba6
--- /dev/null
+++ b/main/polkit-gnome/APKBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=polkit-gnome
+pkgver=0.105
+pkgrel=0
+pkgdesc="PolicyKit integration for the GNOME desktop"
+url="http://www.freedesktop.org/wiki/Software/PolicyKit"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev gtk+3.0-dev polkit-dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://download.gnome.org/sources/polkit-gnome/$pkgver/polkit-gnome-$pkgver.tar.xz
+ polkit-gnome-authentication-agent-1.desktop"
+
+_builddir="$srcdir"/polkit-gnome-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/polkit-gnome \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+ install -Dm644 "${srcdir}/polkit-gnome-authentication-agent-1.desktop" \
+ "${pkgdir}/etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop"
+}
+
+md5sums="50ecad37c8342fb4a52f590db7530621 polkit-gnome-0.105.tar.xz
+147a0534adb37452edb4b27cdb2eabb2 polkit-gnome-authentication-agent-1.desktop"
+sha256sums="1784494963b8bf9a00eedc6cd3a2868fb123b8a5e516e66c5eda48df17ab9369 polkit-gnome-0.105.tar.xz
+ad19e73ae8eba00a8f66bd9afd3e0e1fd7ca22f716e29b97f097d9c01711e0de polkit-gnome-authentication-agent-1.desktop"
+sha512sums="eae2504959bca6f2b53dbad1b743fc0414b82897e62623af80ee74c4080a10d6b07a4c90151ee1264891f27373321b8697ac8a747cba5254c765b4cd9161bd42 polkit-gnome-0.105.tar.xz
+6cf30dcbdb71425603edc804aca9a1bfaf28120614be567db81bdd5b64392445baad8094986f086922795be36b7130f13dd906c56ea576ac85987111d918b0bd polkit-gnome-authentication-agent-1.desktop"