aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-oauth2
diff options
context:
space:
mode:
authorPeter Bui <pnutzh4x0r@gmail.com>2015-07-20 23:16:03 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-21 06:10:51 +0000
commit86c0330d93e2bd69f3b7e546c6a8ba403f2182f2 (patch)
tree3b76aee1506f13ba88b67810a0bbc0061129d4f4 /main/py-oauth2
parent7d8049c92bc2f9af9a687c33f9d4990fe1b55255 (diff)
downloadaports-86c0330d93e2bd69f3b7e546c6a8ba403f2182f2.tar.bz2
aports-86c0330d93e2bd69f3b7e546c6a8ba403f2182f2.tar.xz
main/py-oauth2: move from testing
Diffstat (limited to 'main/py-oauth2')
-rw-r--r--main/py-oauth2/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/py-oauth2/APKBUILD b/main/py-oauth2/APKBUILD
new file mode 100644
index 0000000000..4f7387e30e
--- /dev/null
+++ b/main/py-oauth2/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-oauth2
+_pkgname=oauth2
+pkgver=1.5.211
+pkgrel=0
+pkgdesc="A Python library for OAuth"
+url="https://github.com/simplegeo/python-oauth2"
+arch="noarch"
+license="MIT"
+depends="python py-httplib2"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="987ad7365a70e2286bd1cebb344debbc oauth2-1.5.211.tar.gz"
+sha256sums="82a38f674da1fa496c0fc4df714cbb058540bed72a30c50a2e344b0d984c4d21 oauth2-1.5.211.tar.gz"
+sha512sums="3f5606702d4e305c191c924cab01ee3fc7e170a26460c1d49031e3d9a296b3502d5e18edb1ec0e291abd61797cb47b7b2b8929eff33eb8bc9fd73434b3ab028a oauth2-1.5.211.tar.gz"