aboutsummaryrefslogtreecommitdiffstats
path: root/main/recode
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-01-08 10:29:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-01-08 13:57:53 +0000
commit5d21950a67231990a43562d1f678378ab846647a (patch)
treee050a8e3460a40330f472fe9af94423549691eb9 /main/recode
parent956d74faf5dac34cdd2f4b059877489bf6401663 (diff)
downloadaports-5d21950a67231990a43562d1f678378ab846647a.tar.bz2
aports-5d21950a67231990a43562d1f678378ab846647a.tar.xz
main/recode: move from testing
Diffstat (limited to 'main/recode')
-rw-r--r--main/recode/APKBUILD73
-rw-r--r--main/recode/recode-automake.patch22
-rw-r--r--main/recode/recode-bool-bitfield.patch11
-rw-r--r--main/recode/recode-flex-m4.patch16
-rw-r--r--main/recode/recode-format-security.patch12
5 files changed, 134 insertions, 0 deletions
diff --git a/main/recode/APKBUILD b/main/recode/APKBUILD
new file mode 100644
index 0000000000..2c31c9d95c
--- /dev/null
+++ b/main/recode/APKBUILD
@@ -0,0 +1,73 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=recode
+pkgver=3.6
+pkgrel=0
+pkgdesc="Charset converter tool and library"
+url="https://github.com/pinard/Recode"
+arch="all"
+license="GPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libtool automake autoconf texinfo flex bison"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="Recode-$pkgver.tar.gz::https://github.com/pinard/Recode/archive/v$pkgver.tar.gz
+ recode-automake.patch
+ recode-bool-bitfield.patch
+ recode-flex-m4.patch
+ recode-format-security.patch
+ "
+
+_builddir="$srcdir"/Recode-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ rm -f acinclude.m4 m4/libtool.m4
+ autoreconf -vif
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-nls \
+ --disable-static \
+ --without-included-gettext \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/charset.alias
+}
+
+md5sums="977d5e836dc6540b120d00ecdf14d25d Recode-3.6.tar.gz
+0c9269360d3671e8bc865a16a6243fdd recode-automake.patch
+b2b69d392dbb6ba45b77873d3a3b6ce6 recode-bool-bitfield.patch
+ed5fa897383f1a8f3b15236d2487d3bc recode-flex-m4.patch
+3ab25ae6bba23ddce1c85ed2af251e03 recode-format-security.patch"
+sha256sums="1f0c859350a5fb3c555a7b80080e3238bbf2f0dc50f4009af0a407b3e2865503 Recode-3.6.tar.gz
+dbe524a4bed3901549294089f05fd05b83cf4517541139622e00fc041de952d5 recode-automake.patch
+d48b94231ab9b866dc1abf73de55a5535c8c754751a038fdaf75f3082593a06b recode-bool-bitfield.patch
+b3364355bee4f2ea0939ec0a9d924ab6efa923967daf5ea064fdb1750aef6990 recode-flex-m4.patch
+715731dbf03afbf5be8226a808da75b96180f825d31bba74ed8b9851283e042a recode-format-security.patch"
+sha512sums="0d2ea3e340811ce1172d1a934af20030fb69a940cc86ab6f1bb90a2f81869b91c7f7d2ce503b527d47228140604c465d08661f4f39ae5bdcb28beef1388c3a17 Recode-3.6.tar.gz
+628e3cfddc30c5c4cae5de0a67d9f2539f334a096e8dfaf2aaec04449e1c1f49ab1701a7998d9029506e2935e169fa07c7fbb418c97cbc48497a906f8dc304c8 recode-automake.patch
+b10aa58b2da7a3991d9894bde775ce3ae18d3ab5b6db7941824e0dba871cb30c3c530d32dedfd9be1c7fdd874f956819341c53ae946962441b3b84e1dbebee33 recode-bool-bitfield.patch
+edb4f9a380744ffdabb5775a2d2cfaaa04f491b2fafa7c47f32197394e03607d48c00dcf19a24b486665bd510428a3ba4e4030e3ebd7f832bb453865c69bd868 recode-flex-m4.patch
+093314da6eb2666dcf7a8268366204669aa82df4e5455f28982595a60025d0ccadc989f08868c7ff4d4f49f3298395ce228fa848aed0dcb470063d07ea1dfae1 recode-format-security.patch"
diff --git a/main/recode/recode-automake.patch b/main/recode/recode-automake.patch
new file mode 100644
index 0000000000..d0916c8cbb
--- /dev/null
+++ b/main/recode/recode-automake.patch
@@ -0,0 +1,22 @@
+--- recode-3.6.orig/configure.in 2001-01-03 16:50:54.000000000 +0100
++++ recode-3.6/configure.in 2012-07-23 14:15:28.000000000 +0200
+@@ -15,7 +15,7 @@
+ AM_PROG_LIBTOOL
+
+ AC_ISC_POSIX
+-AM_C_PROTOTYPES
++dnl AM_C_PROTOTYPES
+ AC_C_CONST
+ AC_C_INLINE
+ ad_AC_PROG_FLEX
+--- recode-3.6.orig/src/Makefile.am 2000-12-06 17:36:12.000000000 +0100
++++ recode-3.6/src/Makefile.am 2012-07-23 14:47:07.000000000 +0200
+@@ -17,7 +17,7 @@
+ # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ # 02111-1307, USA.
+
+-AUTOMAKE_OPTIONS = gnits ansi2knr
++AUTOMAKE_OPTIONS = gnits
+ bin_PROGRAMS = recode
+ lib_LTLIBRARIES = librecode.la
+ man_MANS = recode.1
diff --git a/main/recode/recode-bool-bitfield.patch b/main/recode/recode-bool-bitfield.patch
new file mode 100644
index 0000000000..899edc5d7b
--- /dev/null
+++ b/main/recode/recode-bool-bitfield.patch
@@ -0,0 +1,11 @@
+--- a/src/recodext.h.orig 2008-01-16 13:15:39.000000000 +0100
++++ b/src/recodext.h 2008-01-16 13:16:47.000000000 +0100
+@@ -218,7 +218,7 @@
+ enum recode_symbol_type type : 3;
+
+ /* Non zero if this one should be ignored. */
+- bool ignore : 2;
++ bool ignore : 1;
+ };
+
+ struct recode_surface_list
diff --git a/main/recode/recode-flex-m4.patch b/main/recode/recode-flex-m4.patch
new file mode 100644
index 0000000000..e63bdbf25c
--- /dev/null
+++ b/main/recode/recode-flex-m4.patch
@@ -0,0 +1,16 @@
+--- recode-3.6-orig/m4/flex.m4 2000-06-28 16:39:06.000000000 +0200
++++ recode-3.6/m4/flex.m4 2010-07-07 12:23:49.000000000 +0200
+@@ -8,11 +8,8 @@
+ dnl Look for flex or missing, then run AC_PROG_LEX and AC_DECL_YYTEXT
+ AC_DEFUN(ad_AC_PROG_FLEX,
+ [AC_CHECK_PROGS(LEX, flex, missing)
+-if test "$LEX" = missing; then
++AS_IF([test "$LEX" = missing], [
+ LEX="\$(top_srcdir)/$ac_aux_dir/missing flex"
+ LEX_OUTPUT_ROOT=lex.yy
+ AC_SUBST(LEX_OUTPUT_ROOT)dnl
+-else
+- AC_PROG_LEX
+- AC_DECL_YYTEXT
+-fi])
++])])
diff --git a/main/recode/recode-format-security.patch b/main/recode/recode-format-security.patch
new file mode 100644
index 0000000000..756ba3ff56
--- /dev/null
+++ b/main/recode/recode-format-security.patch
@@ -0,0 +1,12 @@
+diff -up recode-3.6/src/names.c.printf recode-3.6/src/names.c
+--- recode-3.6/src/names.c.printf 2000-12-06 20:41:29.000000000 +0100
++++ recode-3.6/src/names.c 2013-12-18 12:48:42.578052395 +0100
+@@ -892,7 +892,7 @@ list_concise_charset (RECODE_OUTER outer
+ if (ucs2 >= 0)
+ printf (format, code);
+ else if (mnemonic || counter2 != 112)
+- printf (blanks);
++ printf ("%s", blanks);
+
+ if (mnemonic)
+ printf (counter2 == 112 ? " %s\n" : " %-3s", mnemonic);