aboutsummaryrefslogtreecommitdiffstats
path: root/main/spice-protocol
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-12-04 16:50:22 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-12-04 16:51:48 +0200
commit585223fdfa2496173856068f7c1663cd319833aa (patch)
tree3a7a8ebac2c64eb46990588356a0b0d5f8f655f7 /main/spice-protocol
parent7db3ca7f0121a93cb15fce7d9f14e09e8850100a (diff)
downloadaports-585223fdfa2496173856068f7c1663cd319833aa.tar.bz2
aports-585223fdfa2496173856068f7c1663cd319833aa.tar.xz
main/spice-protocol: make memory barriers portable
Diffstat (limited to 'main/spice-protocol')
-rw-r--r--main/spice-protocol/APKBUILD15
-rw-r--r--main/spice-protocol/portable-membarrier.patch19
2 files changed, 29 insertions, 5 deletions
diff --git a/main/spice-protocol/APKBUILD b/main/spice-protocol/APKBUILD
index edf2a6523a..9983438c49 100644
--- a/main/spice-protocol/APKBUILD
+++ b/main/spice-protocol/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice-protocol
pkgver=0.12.7
-pkgrel=0
+pkgrel=1
pkgdesc="Spice protocol header files"
url="http://www.spice-space.org/"
arch="noarch"
@@ -12,7 +12,9 @@ depends_dev=""
makedepends="$depends_dev"
install=""
subpackages=""
-source="http://www.spice-space.org/download/releases/spice-protocol-$pkgver.tar.bz2"
+source="http://www.spice-space.org/download/releases/spice-protocol-$pkgver.tar.bz2
+ portable-membarrier.patch
+ "
_builddir="$srcdir"/spice-protocol-$pkgver
prepare() {
@@ -41,6 +43,9 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="799707321e88df4ecd17c4ccb0cc4ffe spice-protocol-0.12.7.tar.bz2"
-sha256sums="96c6cb73361816ed19bfd8536f65d4547da35709aa00af1380e650c1174916c2 spice-protocol-0.12.7.tar.bz2"
-sha512sums="48205ab8daba97f754ae1ac9bbb7071efb2f450c43620839ee70d7577eab2ef696151fcce8f6f5c95b2593c58b6a0d5779e36b6fc0b6d450872ac677ea525800 spice-protocol-0.12.7.tar.bz2"
+md5sums="799707321e88df4ecd17c4ccb0cc4ffe spice-protocol-0.12.7.tar.bz2
+ea0d68301fd623caab0b25aba6031d0d portable-membarrier.patch"
+sha256sums="96c6cb73361816ed19bfd8536f65d4547da35709aa00af1380e650c1174916c2 spice-protocol-0.12.7.tar.bz2
+4def9cbc322b0745c8134a124d7f85e2c4d6e54c4c1e4008f44e68422a58f5d2 portable-membarrier.patch"
+sha512sums="48205ab8daba97f754ae1ac9bbb7071efb2f450c43620839ee70d7577eab2ef696151fcce8f6f5c95b2593c58b6a0d5779e36b6fc0b6d450872ac677ea525800 spice-protocol-0.12.7.tar.bz2
+434b9cc8eed945de181259ae041eb97ee324f4aab54683b14594f9adfbab0ed2dabaaaf15fd696588f3e506809ea6fef86c43e3ac9b05fdd87df242c19b2765c portable-membarrier.patch"
diff --git a/main/spice-protocol/portable-membarrier.patch b/main/spice-protocol/portable-membarrier.patch
new file mode 100644
index 0000000000..20a5ee3318
--- /dev/null
+++ b/main/spice-protocol/portable-membarrier.patch
@@ -0,0 +1,19 @@
+See also: https://bugs.freedesktop.org/show_bug.cgi?id=86997
+
+diff -ru spice-protocol-0.12.7/spice/barrier.h spice-0.12.5/spice-common/spice-protocol/spice/barrier.h
+--- spice-protocol-0.12.7/spice/barrier.h 2013-12-10 20:42:54.000000000 -0200
++++ spice-protocol-0.12.7/spice/barrier.h 2014-12-04 13:45:54.593329844 -0200
+@@ -34,12 +34,7 @@
+
+ #ifdef __GNUC__
+
+-#ifdef __i386__
+-#define spice_mb() __asm__ __volatile__ ("lock; addl $0,0(%%esp)": : :"memory")
+-#else
+-//mfence
+-#define spice_mb() __asm__ __volatile__ ("lock; addl $0,0(%%rsp)": : :"memory")
+-#endif
++#define spice_mb() __sync_synchronize()
+
+ #else
+