aboutsummaryrefslogtreecommitdiffstats
path: root/main/unzip
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-28 01:10:09 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-28 01:10:09 +0200
commit3854f649f7359513f564ac785d8038a64178f6cb (patch)
treef86bbcd73553d8083e83d66d0243f49e2092d997 /main/unzip
parent22e101fc699e3b9f5a2dc1458dd3ebe60f2c3272 (diff)
downloadaports-3854f649f7359513f564ac785d8038a64178f6cb.tar.bz2
aports-3854f649f7359513f564ac785d8038a64178f6cb.tar.xz
main/unzip: improve abuild
Diffstat (limited to 'main/unzip')
-rw-r--r--main/unzip/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/main/unzip/APKBUILD b/main/unzip/APKBUILD
index 81a8f80a6d..2b480f842f 100644
--- a/main/unzip/APKBUILD
+++ b/main/unzip/APKBUILD
@@ -2,35 +2,36 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=unzip
pkgver=6.0
+_pkgver=${pkgver//./}
pkgrel=2
pkgdesc="Extract PKZIP-compatible .zip files"
url="http://www.info-zip.org/UnZip.html"
arch="all"
-license="Custom"
-depends=""
-makedepends=""
+license="custom"
subpackages="$pkgname-doc"
-# normally ftp://ftp.info-zip.org/pub/infozip/src/${pkgname}60.zip
-source="https://dev.alpinelinux.org/archive/unzip/${pkgname}60.tgz
+# normally ftp://ftp.info-zip.org/pub/infozip/src/$pkgname$_pkgver.zip
+source="https://dev.alpinelinux.org/archive/unzip/$pkgname$_pkgver.tgz
10-unzip-handle-pkware-verify.patch
20-unzip-uidgid-fix.patch
unzip-6.0-heap-overflow-infloop.patch
"
+builddir="$srcdir/$pkgname$_pkgver"
-builddir="$srcdir"/${pkgname}60
build() {
cd "$builddir"
+
make -f unix/Makefile \
CC="${CHOST}-gcc" \
LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" \
- prefix=/usr generic || return 1
+ prefix=/usr generic
}
package() {
cd "$builddir"
+
make -f unix/Makefile \
MANDIR=${pkgdir}/usr/share/man/man1/ \
- prefix=${pkgdir}/usr install || return 1
+ prefix=${pkgdir}/usr install
install -Dm644 LICENSE \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}