aboutsummaryrefslogtreecommitdiffstats
path: root/main/wxgtk2.8
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-24 13:23:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-07-24 13:23:50 +0000
commit3c1860a4fcf76285d6e83c0ca0c002d93c776c79 (patch)
tree84b6bc8339371ac99125c7294835ea3295454bde /main/wxgtk2.8
parentd4dc5239fb47d54d442bd13f3beb301115f0be4e (diff)
downloadaports-3c1860a4fcf76285d6e83c0ca0c002d93c776c79.tar.bz2
aports-3c1860a4fcf76285d6e83c0ca0c002d93c776c79.tar.xz
main/wxgtk2.8: fix abi check
Diffstat (limited to 'main/wxgtk2.8')
-rw-r--r--main/wxgtk2.8/APKBUILD13
-rw-r--r--main/wxgtk2.8/wxGTK-2.8.12-abicheck.patch15
2 files changed, 25 insertions, 3 deletions
diff --git a/main/wxgtk2.8/APKBUILD b/main/wxgtk2.8/APKBUILD
index bcc8314e16..a4067f37c8 100644
--- a/main/wxgtk2.8/APKBUILD
+++ b/main/wxgtk2.8/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wxgtk2.8
pkgver=2.8.12.1
-pkgrel=2
+pkgrel=3
pkgdesc="GTK2 port of the wxWidgets GUI library"
url="http://www.wxwidgets.org/"
arch="all"
@@ -15,7 +15,9 @@ makedepends="$depends_dev sdl-dev gst-plugins-base0.10-dev gstreamer0.10-dev
install=""
replaces="wxgtk"
subpackages="$pkgname-dev $pkgname-lang $pkgname-media $pkgname-base"
-source="http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2"
+source="http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2
+ wxGTK-2.8.12-abicheck.patch
+ "
_builddir="$srcdir"/wxPython-src-$pkgver
prepare() {
@@ -77,4 +79,9 @@ base() {
"$subpkgdir"/usr/lib/
}
-md5sums="8c06c5941477beee213b4f2fa78be620 wxPython-src-2.8.12.1.tar.bz2"
+md5sums="8c06c5941477beee213b4f2fa78be620 wxPython-src-2.8.12.1.tar.bz2
+e71ac89e0ed2562d821cfbf1263ce4cb wxGTK-2.8.12-abicheck.patch"
+sha256sums="1f3f153d9f1504c6ce2d2c4b23e940b8f58b81f4cba35cda1a5bb31142243cd0 wxPython-src-2.8.12.1.tar.bz2
+46a1bb97d69163547da13d5e23a4c73e68de27ee601da5d2fb5bc5c417931453 wxGTK-2.8.12-abicheck.patch"
+sha512sums="4f826ccb57d5f4fc03fe7cae67499be70c727a99aebf9d153ea1060a21641642606d44d079ba897c38b176846336aeaebc21d30d5c7a0abec3934d65cf4529f3 wxPython-src-2.8.12.1.tar.bz2
+5b365d9e0f1e7c9a053514010bd78b4192a4472d6ae76590f6999a4bf04d1de0fae5847fac878ab2dd581f4e0ec3959b317e5efacd3bd6628b89c5f65756cf83 wxGTK-2.8.12-abicheck.patch"
diff --git a/main/wxgtk2.8/wxGTK-2.8.12-abicheck.patch b/main/wxgtk2.8/wxGTK-2.8.12-abicheck.patch
new file mode 100644
index 0000000000..97055ba46f
--- /dev/null
+++ b/main/wxgtk2.8/wxGTK-2.8.12-abicheck.patch
@@ -0,0 +1,15 @@
+diff -up wxGTK-2.8.12/src/common/appbase.cpp.abicheck wxGTK-2.8.12/src/common/appbase.cpp
+--- wxGTK-2.8.12/src/common/appbase.cpp.abicheck 2015-03-12 17:15:18.000000000 +0100
++++ wxGTK-2.8.12/src/common/appbase.cpp 2015-03-12 17:15:57.000000000 +0100
+@@ -424,10 +424,7 @@ bool wxAppConsole::CheckBuildOptions(con
+ msg.Printf(_T("Mismatch between the program and library build versions detected.\nThe library used %s,\nand %s used %s."),
+ lib.c_str(), progName.c_str(), prog.c_str());
+
+- wxLogFatalError(msg.c_str());
+-
+- // normally wxLogFatalError doesn't return
+- return false;
++ wxLogWarning(msg.c_str());
+ }
+ #undef wxCMP
+