aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-04-16 14:08:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-04-16 14:08:06 +0000
commit2b77aeb2ad71d9e8693124ace48735998b39f75a (patch)
tree286db073a021eed2ae4c495ff620573719f71bed /main
parent7ef5b998e5e3e004c779cdfdb85d8966122df0a1 (diff)
downloadaports-2b77aeb2ad71d9e8693124ace48735998b39f75a.tar.bz2
aports-2b77aeb2ad71d9e8693124ace48735998b39f75a.tar.xz
main/apache-mod-auth-radius: try fix the apache-2.4 porting
The patch looked wrong. We do new try to fix the remote_ip porting
Diffstat (limited to 'main')
-rw-r--r--main/apache-mod-auth-radius/APKBUILD10
-rw-r--r--main/apache-mod-auth-radius/remote-ip.patch13
2 files changed, 10 insertions, 13 deletions
diff --git a/main/apache-mod-auth-radius/APKBUILD b/main/apache-mod-auth-radius/APKBUILD
index 43b94fa7f5..f731e55c6c 100644
--- a/main/apache-mod-auth-radius/APKBUILD
+++ b/main/apache-mod-auth-radius/APKBUILD
@@ -3,7 +3,7 @@
pkgname=apache-mod-auth-radius
_pkgname=mod_auth_radius
pkgver=1.5.8
-pkgrel=1
+pkgrel=2
pkgdesc="Apache authentication module to become RADIUS client for AAA requests"
url="http://freeradius.org/mod_auth_radius/"
arch="all"
@@ -43,4 +43,10 @@ package() {
md5sums="87d8ef049736254cc09f8b34667f0e59 mod_auth_radius-1.5.8.tar
7021387d32ae7ccb3490ef06ef101b65 mod-auth-radius.conf
-8a68838a41b3dc32ab6f4adc58439a3b remote-ip.patch"
+50775b28edbbf74fd1d99b85447740f9 remote-ip.patch"
+sha256sums="6a16cb64c8e3da5ccef5db007d3ab3fa53274bdb37c5f6b1821a12de42aa6d93 mod_auth_radius-1.5.8.tar
+de656ee2c41d1b05044728d314cae2fff1b1af225b71fc852bc2c244bf24754d mod-auth-radius.conf
+af286dc55ea23c8f5996f72f90c403514000b87de1a76c71f769208dfcffd556 remote-ip.patch"
+sha512sums="0fcc43a44ea17b33595a850abb03ff6b92e100dfbeffc82caa9516f6eb7914fb463cb62286d624203a2c7035d05a107dda7b68c5cedf7de3b8be95b9266b6988 mod_auth_radius-1.5.8.tar
+f5f8bb154e290c4f1d1af899b24ee2011d8fe88fbf31a3fd865e9dfd9927cc8e23cb022be996ec3c43ed79309814ad63efe7f3cd5b3ed670d23a572b3e561f54 mod-auth-radius.conf
+85f58a7d09ee097f61fe691a4cbd777c4208e1daa880d46980c944903a33e70e4ecfacbcccd1d8b6fd175c661b7b0cde7081470c024a89d84f274d2bf3963e24 remote-ip.patch"
diff --git a/main/apache-mod-auth-radius/remote-ip.patch b/main/apache-mod-auth-radius/remote-ip.patch
index 0c461091e9..a675bf01d9 100644
--- a/main/apache-mod-auth-radius/remote-ip.patch
+++ b/main/apache-mod-auth-radius/remote-ip.patch
@@ -1,20 +1,11 @@
--- mod_auth_radius-2.0.c
+++ mod_auth_radius-2.0.c.patched
-@@ -630,7 +630,7 @@
- {
- char one[COOKIE_SIZE], two[COOKIE_SIZE];
- char *cookie = apr_pcalloc(r->pool, COOKIE_SIZE);
-- conn_rec *c = r->connection;
-+ request_rec *c = r->connection;
- server_rec *s = r->server;
- radius_server_config_rec *scr = (radius_server_config_rec *)
- ap_get_module_config (s->module_config, &radius_auth_module);
@@ -680,7 +680,7 @@
* benefit here.
*/
apr_snprintf(one, COOKIE_SIZE, "%s%s%s%s%s%08x", scr->secret,
- r->user, passwd, c->remote_ip, hostname, expires);
-+ r->user, passwd, c->useragent_ip, hostname, expires);
++ r->user, passwd, r->useragent_ip, hostname, expires);
/* if you're REALLY worried about what's going on */
@@ -23,7 +14,7 @@
ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," user = %s\n", r->user);
ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," passwd = %s\n", passwd);
- ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," remote ip = %s\n", c->remote_ip);
-+ ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," remote ip = %s\n", c->useragent_ip);
++ ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," useragent ip = %s\n", r->useragent_ip);
ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," hostname = %s\n", hostname);
ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," expiry = %08x\n", expires);
#endif