aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorOliver Smith <ollieparanoid@bitmessage.ch>2018-09-20 06:57:20 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-09-24 10:19:24 +0300
commit9d9f981a2c421f44db3ae66b90293202748eb9f3 (patch)
tree8790d020333778e4441e1160ef2b17fb6d8e7a0d /main
parent993843fcca32a014f8c0aa87195c4dbed36fdb16 (diff)
downloadaports-9d9f981a2c421f44db3ae66b90293202748eb9f3.tar.bz2
aports-9d9f981a2c421f44db3ae66b90293202748eb9f3.tar.xz
aports: add support for armv7 [skip ci]
This makes it possible to provide armv7 as additional architecture in Alpine, next to armhf. See the discussion in this ML thread: <https://lists.alpinelinux.org/alpine-devel/6271.html> It's done by adding armv7 next to armhf in the arch line and also !armv7 where the arch line said !armhf. The following script was used:
Diffstat (limited to 'main')
-rw-r--r--main/devicemaster-linux-vanilla/APKBUILD2
-rw-r--r--main/gnu-efi/APKBUILD2
-rw-r--r--main/hexchat/APKBUILD2
-rw-r--r--main/linux-rpi/APKBUILD2
-rw-r--r--main/raspberrypi-bootloader/APKBUILD2
-rw-r--r--main/raspberrypi/APKBUILD2
-rw-r--r--main/spl/APKBUILD2
-rw-r--r--main/u-boot/APKBUILD2
-rw-r--r--main/xen/APKBUILD2
-rw-r--r--main/zfs/APKBUILD2
10 files changed, 10 insertions, 10 deletions
diff --git a/main/devicemaster-linux-vanilla/APKBUILD b/main/devicemaster-linux-vanilla/APKBUILD
index b96d1f2bbb..9dde31cf60 100644
--- a/main/devicemaster-linux-vanilla/APKBUILD
+++ b/main/devicemaster-linux-vanilla/APKBUILD
@@ -19,7 +19,7 @@ pkgrel=$(( $_krel + $_rel ))
pkgdesc="NS-Link Device Drivers $_ver for $_kpkg"
url="http://www.comtrol.com/resources/product-resources-white-papers/ns-link-device-drivers"
-arch="x86 x86_64 armhf"
+arch="x86 x86_64 armhf armv7"
license="GPL-2.0"
depends="$_kpkg=$_kpkgver"
makedepends="$_kpkg-dev=$_kpkgver linux-headers"
diff --git a/main/gnu-efi/APKBUILD b/main/gnu-efi/APKBUILD
index 72e20aa927..67f7096bc6 100644
--- a/main/gnu-efi/APKBUILD
+++ b/main/gnu-efi/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.0.4
pkgrel=1
pkgdesc="Development Libraries and headers for EFI"
url="ftp://ftp.hpl.hp.com/pub/linux-ia64"
-arch="all !armhf !ppc64le !s390x"
+arch="all !armhf !armv7 !ppc64le !s390x"
license="BSD"
depends=""
depends_dev=""
diff --git a/main/hexchat/APKBUILD b/main/hexchat/APKBUILD
index 90c9d1bf1c..a5e18c8a32 100644
--- a/main/hexchat/APKBUILD
+++ b/main/hexchat/APKBUILD
@@ -4,7 +4,7 @@ pkgver=2.14.1
pkgrel=1
pkgdesc="Graphical IRC client based on XChat"
url="https://hexchat.github.io"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="GPL-2.0-or-later"
depends=""
makedepends="dbus-glib-dev gtk+2.0-dev iso-codes libnotify-dev libproxy-dev
diff --git a/main/linux-rpi/APKBUILD b/main/linux-rpi/APKBUILD
index 8a3cd47e40..8a5369fdf2 100644
--- a/main/linux-rpi/APKBUILD
+++ b/main/linux-rpi/APKBUILD
@@ -26,7 +26,7 @@ source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
config-changes-rpi2.armhf
"
subpackages=""
-arch="armhf aarch64"
+arch="armhf armv7 aarch64"
license="GPL-2.0"
_flavors=
for _i in $source; do
diff --git a/main/raspberrypi-bootloader/APKBUILD b/main/raspberrypi-bootloader/APKBUILD
index c4857e52cc..08be9d7194 100644
--- a/main/raspberrypi-bootloader/APKBUILD
+++ b/main/raspberrypi-bootloader/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.20180417
pkgrel=0
pkgdesc="Bootloader files for the Raspberry Pi"
url=https://github.com/raspberrypi/firmware
-arch="armhf aarch64"
+arch="armhf armv7 aarch64"
license="custom"
depends=""
makedepends=""
diff --git a/main/raspberrypi/APKBUILD b/main/raspberrypi/APKBUILD
index dae08e69df..437024ff39 100644
--- a/main/raspberrypi/APKBUILD
+++ b/main/raspberrypi/APKBUILD
@@ -5,7 +5,7 @@ _commitid=d491937e8d2f5015c418cbc0c2793020aed4c8e5
pkgrel=0
pkgdesc="Raspberry Pi support tools"
url="https://github.com/raspberrypi/userland"
-arch="armhf aarch64"
+arch="armhf armv7 aarch64"
license="BSD"
depends=""
depends_dev="linux-headers raspberrypi-libs"
diff --git a/main/spl/APKBUILD b/main/spl/APKBUILD
index 194578bc3f..07192290ef 100644
--- a/main/spl/APKBUILD
+++ b/main/spl/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.7.8
pkgrel=0
pkgdesc="Solaris Porting Layer (userland)"
url="http://zfsonlinux.org"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="GPL-2.0-or-later"
options="!check" # No test suite
makedepends="automake autoconf libtool linux-headers"
diff --git a/main/u-boot/APKBUILD b/main/u-boot/APKBUILD
index bf99cc45cb..69dd324c00 100644
--- a/main/u-boot/APKBUILD
+++ b/main/u-boot/APKBUILD
@@ -7,7 +7,7 @@ pkgver=2018.05
pkgrel=2
pkgdesc="u-boot bootloader common files"
url="http://www.denx.de/wiki/U-Boot/"
-arch="armhf aarch64"
+arch="armhf armv7 aarch64"
license="GPL-2.0"
depends=""
depends_dev=""
diff --git a/main/xen/APKBUILD b/main/xen/APKBUILD
index f6e0504afc..6c453d95cc 100644
--- a/main/xen/APKBUILD
+++ b/main/xen/APKBUILD
@@ -6,7 +6,7 @@ pkgver=4.11.0
pkgrel=0
pkgdesc="Xen hypervisor"
url="http://www.xen.org/"
-arch="x86_64 armhf aarch64"
+arch="x86_64 armhf armv7 aarch64"
license="GPL"
depends="bash iproute2 logrotate"
depends_dev="libressl-dev python2-dev e2fsprogs-dev gettext zlib-dev ncurses-dev
diff --git a/main/zfs/APKBUILD b/main/zfs/APKBUILD
index b32327b4f7..db9ffed3d3 100644
--- a/main/zfs/APKBUILD
+++ b/main/zfs/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.7.8
pkgrel=0
pkgdesc="ZFS for Linux"
url="http://zfsonlinux.org"
-arch="all !armhf"
+arch="all !armhf !armv7"
license="CDDL"
depends_dev="glib-dev e2fsprogs-dev util-linux-dev libtirpc-dev attr-dev"
makedepends="$depends_dev automake autoconf libtool linux-headers"