aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-05-19 14:47:22 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-19 14:47:22 +0200
commit042d94c4e91008067052d4f9601d4b76af80e2d1 (patch)
tree9e15e8b7f7ecc3aca3b70dbca3287a9157c36c8b /main
parent957c515e9347dda1a578ec63007a5ebe729762cb (diff)
downloadaports-042d94c4e91008067052d4f9601d4b76af80e2d1.tar.bz2
aports-042d94c4e91008067052d4f9601d4b76af80e2d1.tar.xz
main/alpine-conf: tiny setup-keymap enhancement
add useful feature for people who runs it often
Diffstat (limited to 'main')
-rw-r--r--main/alpine-conf/0001-setup-keymap-allow-specify-the-variant-together-with.patch36
-rw-r--r--main/alpine-conf/APKBUILD6
2 files changed, 40 insertions, 2 deletions
diff --git a/main/alpine-conf/0001-setup-keymap-allow-specify-the-variant-together-with.patch b/main/alpine-conf/0001-setup-keymap-allow-specify-the-variant-together-with.patch
new file mode 100644
index 0000000000..3214d0bc4f
--- /dev/null
+++ b/main/alpine-conf/0001-setup-keymap-allow-specify-the-variant-together-with.patch
@@ -0,0 +1,36 @@
+From be87a08bc2200b80c068347568bea07a4fa09fb7 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 19 May 2017 14:39:35 +0200
+Subject: [PATCH] setup-keymap: allow specify the variant together with layout
+
+Some users may know exactly which variant they want, and instead of
+asking them two questions, we accept if users types in the variant at
+the first question.
+
+if the variant does not exist, then user is prompted.
+---
+ setup-keymap.in | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/setup-keymap.in b/setup-keymap.in
+index 67f89cb..ebcd29c 100644
+--- a/setup-keymap.in
++++ b/setup-keymap.in
+@@ -38,7 +38,13 @@ select_layout() {
+ default_read layout "$layout"
+ if [ "$layout" = "abort" ] || [ "$layout" = "none" ] ; then
+ goodbye 0
+- elif [ -d "$MAPDIR/$layout" ] ; then
++ fi
++ set -- $layout
++ if [ $# -eq 2 ]; then
++ layout="$1"
++ variant="$2"
++ fi
++ if [ -d "$MAPDIR/$layout" ] ; then
+ return 0
+ fi
+ done
+--
+2.13.0
+
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 8027b15875..619f95e2bb 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=3.6.0_rc1
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
arch="all"
license="MIT"
depends="openrc>0.13 busybox>=1.26.1-r3"
source="http://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.xz
+ 0001-setup-keymap-allow-specify-the-variant-together-with.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -24,4 +25,5 @@ package() {
done
}
-sha512sums="3d1b7c18a406791948485cd871942b94a0f2eadd6f1f0e9c87f92fb15750b9b41ffec0d7d2d16361a1e25f029765005e72b266ce48609ea0b7c5e5c99606d04f alpine-conf-3.6.0_rc1.tar.xz"
+sha512sums="3d1b7c18a406791948485cd871942b94a0f2eadd6f1f0e9c87f92fb15750b9b41ffec0d7d2d16361a1e25f029765005e72b266ce48609ea0b7c5e5c99606d04f alpine-conf-3.6.0_rc1.tar.xz
+67a1d72e45ba74d710a841c0a2671f74f792f6649fb530f86763fe2f10fc0005c644dfdcec25b00bc5eb0b97b2418775e95202269ef3b3f56b6c22044630fb86 0001-setup-keymap-allow-specify-the-variant-together-with.patch"