aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-10-16 14:10:04 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2018-10-16 14:11:13 -0500
commit4076ab5853ca7dca9a1f1ea70601f83c881a2a4a (patch)
tree7a3f8d9d11dea9574465dc4f40560a69f0f7069c /main
parenta4242e97d4a33e05b5678fc2fabc361310bc5184 (diff)
downloadaports-4076ab5853ca7dca9a1f1ea70601f83c881a2a4a.tar.bz2
aports-4076ab5853ca7dca9a1f1ea70601f83c881a2a4a.tar.xz
main/python3: make xattr functions work (from adelie)
Diffstat (limited to 'main')
-rw-r--r--main/python3/APKBUILD4
-rw-r--r--main/python3/fix-xattrs-glibc.patch15
2 files changed, 18 insertions, 1 deletions
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index ae7359d2f0..7c5ec7dc6f 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -5,7 +5,7 @@ pkgname=python3
# the python2-tkinter's pkgver needs to be synchronized with this.
pkgver=3.6.6
_basever="${pkgver%.*}"
-pkgrel=0
+pkgrel=1
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -16,6 +16,7 @@ subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-tests::noarch
makedepends="expat-dev libressl-dev zlib-dev ncurses-dev bzip2-dev xz-dev
sqlite-dev libffi-dev tcl-dev linux-headers gdbm-dev readline-dev"
source="https://www.python.org/ftp/python/$pkgver/Python-$pkgver.tar.xz
+ fix-xattrs-glibc.patch
musl-find_library.patch
"
builddir="$srcdir/Python-$pkgver"
@@ -141,4 +142,5 @@ wininst() {
}
sha512sums="c71f87c5906e770322a14cacad228655659f782207db826320449d12bf86091c3662f317e1773158dec52f8b052eaedfb4c03b561cc2a6cfcd381597fd2d2b04 Python-3.6.6.tar.xz
+37b6ee5d0d5de43799316aa111423ba5a666c17dc7f81b04c330f59c1d1565540eac4c585abe2199bbed52ebe7426001edb1c53bd0a17486a2a8e052d0f494ad fix-xattrs-glibc.patch
ab8eaa2858d5109049b1f9f553198d40e0ef8d78211ad6455f7b491af525bffb16738fed60fc84e960c4889568d25753b9e4a1494834fea48291b33f07000ec2 musl-find_library.patch"
diff --git a/main/python3/fix-xattrs-glibc.patch b/main/python3/fix-xattrs-glibc.patch
new file mode 100644
index 0000000000..57a8fb73ab
--- /dev/null
+++ b/main/python3/fix-xattrs-glibc.patch
@@ -0,0 +1,15 @@
+diff --git a/Modules/posixmodule.c b/Modules/posixmodule.c
+index 8f8ba25..72b92da 100644
+--- a/Modules/posixmodule.c
++++ b/Modules/posixmodule.c
+@@ -103,8 +103,9 @@ corresponding Unix manual entries for more information on calls.");
+ #undef HAVE_SCHED_SETAFFINITY
+ #endif
+
+-#if defined(HAVE_SYS_XATTR_H) && defined(__GLIBC__) && !defined(__FreeBSD_kernel__) && !defined(__GNU__)
++#if defined(HAVE_SYS_XATTR_H) && defined(__linux__) && !defined(__FreeBSD_kernel__) && !defined(__GNU__)
+ #define USE_XATTRS
++#include <linux/limits.h>
+ #endif
+
+ #ifdef USE_XATTRS