aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@alpinelinux.org>2018-01-21 13:50:21 -0500
committerTimo Teräs <timo.teras@iki.fi>2018-02-01 20:14:40 +0000
commit6a9f2a91c955bce8a4e2d2ad2fe1b919acf0155c (patch)
tree43ea30db1566925161a68c69af053be798459379 /main
parentaeab50c64318f49054e86eb7692f1c2925f904ce (diff)
downloadaports-6a9f2a91c955bce8a4e2d2ad2fe1b919acf0155c.tar.bz2
aports-6a9f2a91c955bce8a4e2d2ad2fe1b919acf0155c.tar.xz
main/gpsd version bump to 3.17
Diffstat (limited to 'main')
-rw-r--r--main/gpsd/APKBUILD8
-rw-r--r--main/gpsd/gpsd-use-local-timepps-header.patch14
2 files changed, 14 insertions, 8 deletions
diff --git a/main/gpsd/APKBUILD b/main/gpsd/APKBUILD
index 2c12158b08..6852efda61 100644
--- a/main/gpsd/APKBUILD
+++ b/main/gpsd/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Nathan Angelacos <nangel@alpinelinux.org>
# Maintainer: Nathan Angelacos <nangel@alpinelinux.org>
pkgname=gpsd
-pkgver=3.16
-pkgrel=3
+pkgver=3.17
+pkgrel=0
pkgdesc="A GPS daemon"
arch=all
url="http://catb.org/gpsd/"
@@ -54,9 +54,9 @@ package() {
install -m644 -D "$srcdir"/gpsd.confd "$pkgdir"/etc/conf.d/gpsd
}
-sha512sums="a8ad85a1f17d3ea550a4b99c262e47a834ed8fd16b00e10574f7cf5f34b6c506142aa77a870a61f8827c0d0c88fe7f65f6e916089d64e84c5667d4a2ca89c543 gpsd-3.16.tar.gz
+sha512sums="71085053f600730e0f2de269c59ce0a17ae106ef01403f02d78418b267c6adb9818d541fba59eb23bf71cdb67c5442c82b4948d262ef7e74bb993dcae677a1b1 gpsd-3.17.tar.gz
eb11fc19243d1789016d88eb7645bfe67c46304547781489bf36eb1dd4c252d523681ff835a6488fa0ef62b6b9e2f781c672279f4439f5d5640a3f214a113048 timepps.h
-1802e72c9ac71a162fcd37d99dc9c8596b6085180dba9b37f24f2b17344d16cd5f618228f43bfdc2f7509f9a2f1072c2b11c238486febcdb94d9d0d095eaebdd gpsd-use-local-timepps-header.patch
+ca534795df3033f15a2cd2f8cc6de5d71608f30418887f31df6dc1db1f283d5cf82920923a1a4adbcaa147e9e32458eee46aed3d64a9a83c950bb83d5e9d4f6e gpsd-use-local-timepps-header.patch
e2af8f52fc2d7e663882b6d12c5f4d709aa267b16eb9aeca2a70d8ecc681ae72359f3efcd1636cde576bc8579e008f242574bc0adfab7252d3e763f039e86135 ttydefaults.patch
a0e7bf206ad51c31195f86f79ef92adca425d7f988534c0f70a2dd3053613f6fc46820d62d0330aaef7ca100b5f2ab781ce9643f25b4c99c844ae66e7eec5cbc gpsd.initd
55d4a51f82d445d3ac93b2855132ef4380908ed045feba6298ed1d0b607cd9054b5325c024dc52b370983ebd5d9b377537aee7d7128c97aa22e3075f4134d404 gpsd.confd"
diff --git a/main/gpsd/gpsd-use-local-timepps-header.patch b/main/gpsd/gpsd-use-local-timepps-header.patch
index 4724e43ed5..ea27de7a3e 100644
--- a/main/gpsd/gpsd-use-local-timepps-header.patch
+++ b/main/gpsd/gpsd-use-local-timepps-header.patch
@@ -1,13 +1,19 @@
diff --git a/ppsthread.c b/ppsthread.c
-index 5fae444..d09957b 100644
+index 6819c6f..45002cb 100644
--- a/ppsthread.c
+++ b/ppsthread.c
-@@ -72,7 +72,7 @@
+@@ -75,12 +75,11 @@
+ */
+ #define FAKE_PPS_NAME "ktimer"
+
+-#if defined(HAVE_SYS_TIMEPPS_H)
++// We supply our own timepps.h for Linux
+ // include unistd.h here as it is missing on older pps-tools releases.
// 'close' is not defined otherwise.
#include <unistd.h>
- #include <sys/time.h>
-#include <sys/timepps.h>
+-#endif
+#include "sys/timepps.h"
- #endif
#include "timespec.h"
+ #include "ppsthread.h"