aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorDaniel Isaksen <d@duniel.no>2018-01-30 23:30:16 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-01-30 23:34:16 +0000
commit8b198b0998db2476459d39307b6b2996737a4298 (patch)
tree5d7fe25002db1016866a23bbfa9fe5a8b68c33b3 /main
parent5d371c045d81d2bd535a6e5589300b7b77b8cbe3 (diff)
downloadaports-8b198b0998db2476459d39307b6b2996737a4298.tar.bz2
aports-8b198b0998db2476459d39307b6b2996737a4298.tar.xz
main/patchwork: bump to 2.0.1
Diffstat (limited to 'main')
-rw-r--r--main/patchwork/0001-support-busybox-readlink.patch16
-rw-r--r--main/patchwork/0002-remove-uneeded-bashism-from-tools-and-change-path.patch26
-rw-r--r--main/patchwork/APKBUILD8
3 files changed, 25 insertions, 25 deletions
diff --git a/main/patchwork/0001-support-busybox-readlink.patch b/main/patchwork/0001-support-busybox-readlink.patch
index 8397b56b48..3918b58f0e 100644
--- a/main/patchwork/0001-support-busybox-readlink.patch
+++ b/main/patchwork/0001-support-busybox-readlink.patch
@@ -1,13 +1,13 @@
diff --git a/patchwork/bin/parsemail.sh b/patchwork/bin/parsemail.sh
-index c8220a7..d363692 100755
+index a742f60e54..14a608616c 100755
--- a/patchwork/bin/parsemail.sh
+++ b/patchwork/bin/parsemail.sh
@@ -20,7 +20,7 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
- BIN_DIR=`dirname $0`
--PATCHWORK_BASE=`readlink -e $BIN_DIR/../..`
-+PATCHWORK_BASE=`readlink -f $BIN_DIR/../..`
-
- PYTHONPATH="$PATCHWORK_BASE":"$PATCHWORK_BASE/lib/python:$PYTHONPATH" \
- DJANGO_SETTINGS_MODULE=patchwork.settings.production \
+
+ BIN_DIR=$(dirname "$0")
+-PATCHWORK_BASE=$(readlink -e "$BIN_DIR/../..")
++PATCHWORK_BASE=$(readlink -f "$BIN_DIR/../..")
+
+ if [ -z "$PW_PYTHON" ]; then
+ PW_PYTHON=python2
diff --git a/main/patchwork/0002-remove-uneeded-bashism-from-tools-and-change-path.patch b/main/patchwork/0002-remove-uneeded-bashism-from-tools-and-change-path.patch
index d668dde0bd..858568f7be 100644
--- a/main/patchwork/0002-remove-uneeded-bashism-from-tools-and-change-path.patch
+++ b/main/patchwork/0002-remove-uneeded-bashism-from-tools-and-change-path.patch
@@ -1,29 +1,29 @@
diff --git a/tools/patchwork-update-commits b/tools/patchwork-update-commits
-index 820fd1c..ca0022a 100755
+index c84a6305e3..2d34f4f9a9 100755
--- a/tools/patchwork-update-commits
+++ b/tools/patchwork-update-commits
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
-
- toolsdir="$(dirname "$0")"
- pwpath="${toolsdir}"/../patchwork
+ #
+ # Patchwork - automated patch tracking system
+ # Copyright (C) 2010 Jeremy Kerr <jk@ozlabs.org>
diff --git a/tools/post-receive.hook b/tools/post-receive.hook
-index 8f05b8d..3d6ec1b 100755
+index 8098ce825a..b8a1fd2f2a 100755
--- a/tools/post-receive.hook
+++ b/tools/post-receive.hook
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
+ # Patchwork - automated patch tracking system
+ # Copyright (C) 2010 martin f. krafft <madduck@madduck.net>
#
+@@ -21,7 +21,7 @@
# Git post-receive hook to update Patchwork patches after Git pushes
- #
-@@ -15,7 +15,7 @@ STATE_MAP="refs/heads/master:Accepted"
- #
- EXCLUDE=""
+ set -eu
--PWDIR=/srv/patchwork/patchwork
-+PWDIR=/usr/share/webapps/patchwork/patchwork
+-PW_DIR=/opt/patchwork/patchwork
++PW_DIR=/usr/share/webapps/patchwork/patchwork
- do_exit=0
- trap "do_exit=1" INT
+ #TODO: the state map should really live in the repo's git-config
+ STATE_MAP="refs/heads/master:Accepted"
diff --git a/main/patchwork/APKBUILD b/main/patchwork/APKBUILD
index 3b45b6004d..787d0f3012 100644
--- a/main/patchwork/APKBUILD
+++ b/main/patchwork/APKBUILD
@@ -1,7 +1,7 @@
# Con#tributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
-pkgver=1.1.3
+pkgver=2.0.1
pkgrel=0
pkgdesc="Web-based patch tracking system"
url="https://github.com/getpatchwork/patchwork"
@@ -75,8 +75,8 @@ pwclient() {
"$subpkgdir"/usr/bin/pwclient
}
-sha512sums="e718ce942781c64e672c7ce9df4362277df418ba2adb61d8b512bf11ffd275d675f972703ceb301600e9b9914741f9b7f44229c1f1e5dec1470ce72b15a4598b patchwork-1.1.3.tar.gz
-a5d4e24741b66092a39c1ef4fdc76dffa1ddf87a69544ab0c374fb0701b0f7340a62ead86835d9bb412df5713f3ea3c0218e9e2e0cd01d9a1aad9414a3cc75fa 0001-support-busybox-readlink.patch
-12d1b184c6cb1d3f2c51adab6b60638e4869e055e677897bb66ee1a52312e77817bec543842324e2cbc2c226f3ab9d11c3782b5ef3a6f5f5712996cadbc6c9c9 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
+sha512sums="95dcfcdf19de0a65a77ab4274de82457c969e3a65705da25cbec742e4d6671e51e629d5366d47ee510a1ac622afde3e2637fa4a013fd576a66808be75a7e84b5 patchwork-2.0.1.tar.gz
+5facc2c2620b2d614011bcdc06bb481fb1481c79333579e5a7fa5b8bc4f97d1651cc8c4632a5e150b62674d64c00345341229319f1edb2016721868e84146826 0001-support-busybox-readlink.patch
+f6d3590b3ac53797e0ae25fe50ab0935608be5ded44665599cbc91e93558895eddc6a7a717153d81fc194b314d7854686577ef5ecf9e0302b7824ce3b3863f7b 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
28911a25e00a254237f7214fb681e5e984a2eae331e610be62967d5e246958e0f8d3f84861d8fd17c1190c1df72a25f28ddb33843b3679a3864beb00cb4b4961 nginx-uwsgi-patchwork-conf.ini
862dd2522236a0b18d2a8d06f1ad91ad0fd0936fa502d95e09556641e67d42e1212821bfd7fb98923e4fe8b8a7369ded8c23831fb496b1e2833d9831c1b23725 nginx-patchwork.conf"