aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-10-15 22:06:00 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-10-15 22:07:44 +0200
commitd189ee0167c4adfd06b0816e1ffcaaa31c65201a (patch)
tree860b88a088b2a281642c4fa29a3ea46d510eaf55 /main
parent4b831f27dca3298740b9e5786dfcf9536f997365 (diff)
downloadaports-d189ee0167c4adfd06b0816e1ffcaaa31c65201a.tar.bz2
aports-d189ee0167c4adfd06b0816e1ffcaaa31c65201a.tar.xz
main/libxshmfence: fix build failure
The `-D_GNU_SOURCE` is needed for the memfd_create function prototype in `sys/memfd.h`. Without this change the build fails with the following error message: xshmfence_alloc.c:73:7: error: implicit declaration of function 'memfd_create' fd = memfd_create("xshmfence", MFD_CLOEXEC|MFD_ALLOW_SEALING); ^~~~~~~~~~~~
Diffstat (limited to 'main')
-rw-r--r--main/libxshmfence/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/libxshmfence/APKBUILD b/main/libxshmfence/APKBUILD
index 89f21cda0e..501645e209 100644
--- a/main/libxshmfence/APKBUILD
+++ b/main/libxshmfence/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=libxshmfence
pkgver=1.2
-pkgrel=3
+pkgrel=4
pkgdesc="X11 shared memory fences"
url="https://www.x.org/"
arch="all"
@@ -16,7 +16,7 @@ source="https://www.x.org/releases/individual/lib/libxshmfence-$pkgver.tar.bz2"
build() {
cd "$builddir"
- ./configure \
+ CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \