aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apk-autoupdate
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-03 14:50:36 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-03 14:50:56 +0200
commit1290d9e9585711bf5943d78abfd3f594f58ad01a (patch)
tree9e25240e6c9400a1bac3b6ef46abed03d7b49e03 /testing/apk-autoupdate
parenta15512e1bb08d557df857a447e1c3c9b52c96011 (diff)
downloadaports-1290d9e9585711bf5943d78abfd3f594f58ad01a.tar.bz2
aports-1290d9e9585711bf5943d78abfd3f594f58ad01a.tar.xz
testing/apk-autoupdate: new aport
https://github.com/jirutka/apk-autoupdate/ Alpine's tool for automatic updates
Diffstat (limited to 'testing/apk-autoupdate')
-rw-r--r--testing/apk-autoupdate/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/apk-autoupdate/APKBUILD b/testing/apk-autoupdate/APKBUILD
new file mode 100644
index 0000000000..cf920afdc0
--- /dev/null
+++ b/testing/apk-autoupdate/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=apk-autoupdate
+pkgver=0_git20180503
+pkgrel=0
+_gitrev=881b6ba1f562f4bc07132f75adddd81439b5e312
+pkgdesc="Alpine's tool for automatic updates"
+url="https://github.com/jirutka/apk-autoupdate/"
+arch="all"
+license="MIT"
+depends="apk-tools"
+makedepends="asciidoctor"
+subpackages="$pkgname-doc"
+source="$pkgname-$_gitrev.tar.gz::https://github.com/jirutka/$pkgname/archive/$_gitrev.tar.gz"
+builddir="$srcdir/$pkgname-$_gitrev"
+
+build() {
+ cd "$builddir"
+ make build
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" prefix=/usr
+}
+
+sha512sums="b1978d2a53311d4952901bb498526134f6238516b3651db162b1f172fac7cffa31957cb5f003fc32fa10589a08b1118d8ae1bd28c71aaff17bd64625ae3c4d00 apk-autoupdate-881b6ba1f562f4bc07132f75adddd81439b5e312.tar.gz"