aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bchunk
diff options
context:
space:
mode:
authorAlexander Edland <s@ocv.me>2018-08-05 04:35:42 +0200
committerShiz <hi@shiz.me>2018-08-05 20:56:50 +0200
commit2bb31b57f367ce754eeada62251916e59ba5ee14 (patch)
tree2cfd588b6f8ed13463dc071535c86ea175ca7ffe /testing/bchunk
parenta03670144523a8f9480f1218123121b34edd6f17 (diff)
downloadaports-2bb31b57f367ce754eeada62251916e59ba5ee14.tar.bz2
aports-2bb31b57f367ce754eeada62251916e59ba5ee14.tar.xz
testing/bchunk: new aport
Diffstat (limited to 'testing/bchunk')
-rw-r--r--testing/bchunk/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/bchunk/APKBUILD b/testing/bchunk/APKBUILD
new file mode 100644
index 0000000000..25eeaf74e2
--- /dev/null
+++ b/testing/bchunk/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Alexander Edland <alpine@ocv.me>
+# Maintainer: Alexander Edland <alpine@ocv.me>
+pkgname=bchunk
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="Convert bin+cue CD images to .iso and .cdr"
+url="https://github.com/hessu/bchunk"
+arch="all"
+license="GPL-2.0-or-later"
+options="!check" # no test suite
+subpackages="$pkgname-doc"
+source="bchunk-$pkgver.tar.gz::https://github.com/hessu/bchunk/archive/release/$pkgver.tar.gz"
+builddir="$srcdir/bchunk-release-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p \
+ "$pkgdir/usr/bin" \
+ "$pkgdir/usr/share/man/man1"
+
+ sed -ri '/^(BIN|MAN)_DIR /d' Makefile
+ make -j1 \
+ BIN_DIR="$pkgdir/usr/bin" \
+ MAN_DIR="$pkgdir/usr/share/man" \
+ install
+}
+
+sha512sums="d99f5a98944d6dab269865489843a39748b0fa1cd7dc5ec4e2a8d0ecc6223f196eed6c1d8d325822b4d548d9bb03eee151fdab7b867aaa79930f6e751175d459 bchunk-1.2.2.tar.gz"