aboutsummaryrefslogtreecommitdiffstats
path: root/testing/botan
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-02-08 13:38:08 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-07 09:22:15 +0000
commit88aa822566902e23735863b3f107d9479a528e2e (patch)
tree00e7bc66350bb5ea530f930b60ca1066550b574c /testing/botan
parentc1f788b21a12f0b760330eba5cfbf200d05bd617 (diff)
downloadaports-88aa822566902e23735863b3f107d9479a528e2e.tar.bz2
aports-88aa822566902e23735863b3f107d9479a528e2e.tar.xz
testing/botan: new aport
https://botan.randombit.net/ Crypto and TLS for C++11
Diffstat (limited to 'testing/botan')
-rw-r--r--testing/botan/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/botan/APKBUILD b/testing/botan/APKBUILD
new file mode 100644
index 0000000000..0bbed4d0ed
--- /dev/null
+++ b/testing/botan/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: tcely <tcely@users.noreply.github.com>
+# Maintainer:
+pkgname=botan
+_pkgreal=Botan
+pkgver=2.4.0
+pkgrel=0
+pkgdesc="Crypto and TLS for C++11"
+url="https://botan.randombit.net/"
+arch="x86_64 x86"
+license="BSD-2-Clause"
+depends=""
+depends_dev="python2 boost-dev libressl-dev sqlite-dev bzip2-dev zlib-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://botan.randombit.net/releases/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+install=""
+
+build() {
+ cd "$builddir"
+ ./configure.py \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-boost \
+ --with-openssl \
+ --with-sqlite3 \
+ --with-bzip2 \
+ --with-zlib
+ make
+}
+
+check() {
+ cd "$builddir"
+
+ LD_LIBRARY_PATH=. python2 src/python/botan2.py
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/lib/python*
+}
+
+sha512sums="304663a7af280f206305b4a782bf77531547b8ab86bd4df89f03a1e11f3b70b8514ed2b8a4de545415efde83085678d7cf28e443aa9e80337a8b28274af6ae0e Botan-2.4.0.tgz"