aboutsummaryrefslogtreecommitdiffstats
path: root/testing/botan
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-07-16 07:45:06 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-16 14:42:59 +0000
commitfa338c84f5c186bc45440fbb16c0152cc763faf7 (patch)
treea95ed72d8f900ef524e87de3e2fdf3b33e1e4164 /testing/botan
parentabbc5024d4e18f26475d75f8cfb60bd09c8720ed (diff)
downloadaports-fa338c84f5c186bc45440fbb16c0152cc763faf7.tar.bz2
aports-fa338c84f5c186bc45440fbb16c0152cc763faf7.tar.xz
testing/botan: security upgrade to 2.7.0
Diffstat (limited to 'testing/botan')
-rw-r--r--testing/botan/APKBUILD13
-rw-r--r--testing/botan/add-armv8l-alias.patch23
2 files changed, 7 insertions, 29 deletions
diff --git a/testing/botan/APKBUILD b/testing/botan/APKBUILD
index e2ff45b59f..53a8041b76 100644
--- a/testing/botan/APKBUILD
+++ b/testing/botan/APKBUILD
@@ -1,7 +1,8 @@
# Contributor: tcely <tcely@users.noreply.github.com>
# Maintainer:
pkgname=botan
-pkgver=2.6.0
+_pkgname=Botan
+pkgver=2.7.0
pkgrel=0
pkgdesc="Crypto and TLS for C++11"
url="https://botan.randombit.net/"
@@ -11,12 +12,13 @@ depends=""
depends_dev="boost-dev bzip2-dev libressl-dev sqlite-dev xz-dev zlib-dev"
makedepends="$depends_dev python2"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://botan.randombit.net/releases/Botan-$pkgver.tgz
- add-armv8l-alias.patch"
-builddir="$srcdir/Botan-$pkgver"
+source="https://botan.randombit.net/releases/$_pkgname-$pkgver.tgz"
+builddir="$srcdir/$_pkgname-$pkgver"
install=""
# secfixes:
+# 2.7.0-r0:
+# - CVE-2018-12435
# 2.6.0-r0:
# - CVE-2018-9860
# 2.5.0-r0:
@@ -54,5 +56,4 @@ package() {
rm -rf "$pkgdir"/usr/lib/python*
}
-sha512sums="2082b4aaac0802f117a5f75c67a69e6d364b436a0ebe543032e370c3f085752bbe1ca48051462066e13bd42e47573ebc532d1d45074fe406df032f33346ee645 Botan-2.6.0.tgz
-d43abb73a852e8370940dc7ef51e564c57d21365a2d5c04581ff9b5926a11e0a1c0e2f2e2821932f63649335f8606a789a3467e6ecfad4da76a2598ef5bce6ff add-armv8l-alias.patch"
+sha512sums="992138d83e18aedf80337d825f80c34dd3d2177eb30967573c57cf9fb7e7f9a9965ae3d75f23635f4c93b4efb7bb5adbb3423702663c78a5eb905dd567561858 Botan-2.7.0.tgz"
diff --git a/testing/botan/add-armv8l-alias.patch b/testing/botan/add-armv8l-alias.patch
deleted file mode 100644
index 61075c6217..0000000000
--- a/testing/botan/add-armv8l-alias.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 60fc5e9e739a642c0bd9396efff35897381caa1e Mon Sep 17 00:00:00 2001
-From: tcely <tcely@users.noreply.github.com>
-Date: Tue, 17 Apr 2018 19:29:17 -0400
-Subject: [PATCH] Recognize armv8l [ci skip]
-
-Addresses https://github.com/randombit/botan/issues/1543
----
- src/build-data/arch/arm32.txt | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/build-data/arch/arm32.txt b/src/build-data/arch/arm32.txt
-index 38e7dcab88..d2fe782b3b 100644
---- a/src/build-data/arch/arm32.txt
-+++ b/src/build-data/arch/arm32.txt
-@@ -11,6 +11,8 @@ evbarm # For NetBSD
- armv7
- armv7l
- armv7-a
-+
-+armv8l # For AlpineLinux
- </aliases>
-
- <isa_extensions>