aboutsummaryrefslogtreecommitdiffstats
path: root/testing/capstone
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/capstone
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/capstone')
-rw-r--r--testing/capstone/APKBUILD45
-rw-r--r--testing/capstone/capstone.pc8
2 files changed, 0 insertions, 53 deletions
diff --git a/testing/capstone/APKBUILD b/testing/capstone/APKBUILD
deleted file mode 100644
index dc5322237a..0000000000
--- a/testing/capstone/APKBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Maintainer: Valery Kartel <valery.kartel@gmail.com>
-pkgname=capstone
-pkgver=3.0.4
-pkgrel=0
-pkgdesc="The Ultimate Disassembler"
-url="http://www.capstone-engine.org"
-arch="all"
-license="LGPLv2"
-depends=""
-depends_dev="$pkgname"
-makedepends="cmake"
-install=""
-subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/aquynh/$pkgname/archive/$pkgver.tar.gz
- $pkgname.pc"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-build() {
- cd "$_builddir"
- cmake CMakeLists.txt \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCAPSTONE_BUILD_STATIC=OFF \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- install -Dm644 "$srcdir"/$pkgname.pc "$pkgdir"/usr/lib/pkgconfig/$pkgname.pc
- sed -i \
- -e "s/#pkgname/$pkgname/" \
- -e "s/#pkgdesc/$pkgdesc/" \
- -e "s/#pkgver/$pkgver/" \
- "$pkgdir"/usr/lib/pkgconfig/$pkgname.pc
-}
-
-md5sums="203a3593552afd844b0d7da0f56d21d2 capstone-3.0.4.tar.gz
-bcbbe0e5250a246705668638778b9a29 capstone.pc"
-sha256sums="5d6dadf5864c56f8de66c66088fa68e849d0bff6577865a4f81b6f23112b14f2 capstone-3.0.4.tar.gz
-6bfbcd218a9f25ad1b30a45ec698cbfb0c41cf17202bd034d7d4057eafa9c4cd capstone.pc"
-sha512sums="a5c29e7c559b5391d6a4ec9a7f766699ea6d321aa2f1fc57fdcec893107fa3ef2f5f6323629971c1129f1ca087df4f3ad03d0a8234d2eae368c8ccfec04dbf4d capstone-3.0.4.tar.gz
-87eacef80df36be18fe86f540a452b7e290c9dfc85d01c7926d263f2e5060f6d5fd6a6c68c350caf532f4926902a77fba24e59cb5e9b606be9706980ae4c8235 capstone.pc"
diff --git a/testing/capstone/capstone.pc b/testing/capstone/capstone.pc
deleted file mode 100644
index d6c5d1ecde..0000000000
--- a/testing/capstone/capstone.pc
+++ /dev/null
@@ -1,8 +0,0 @@
-libdir=/usr/lib
-includedir=/usr/include
-
-Name: #pkgname
-Version: #pkgver
-Description: #pkgdesc
-Libs: -L${libdir} -l#pkgname
-Cflags: -I${includedir}