aboutsummaryrefslogtreecommitdiffstats
path: root/testing/checkpolicy
diff options
context:
space:
mode:
authorTycho Andersen <tycho@docker.com>2017-03-22 15:04:45 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-03-23 01:55:04 +0100
commit195ce013b398ccd7d8815142e2dda146e7daf0e0 (patch)
tree9770f8ae5e816f48520a8720529a2401116ebfa8 /testing/checkpolicy
parent9e029de2c6353726de596359af6b42ae65a13f93 (diff)
downloadaports-195ce013b398ccd7d8815142e2dda146e7daf0e0.tar.bz2
aports-195ce013b398ccd7d8815142e2dda146e7daf0e0.tar.xz
testing/checkpolicy: new aport
http://www.selinuxproject.org SELinux policy checker
Diffstat (limited to 'testing/checkpolicy')
-rw-r--r--testing/checkpolicy/0001-remove-apple-ifdef.patch16
-rw-r--r--testing/checkpolicy/APKBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/testing/checkpolicy/0001-remove-apple-ifdef.patch b/testing/checkpolicy/0001-remove-apple-ifdef.patch
new file mode 100644
index 0000000000..7f50510be2
--- /dev/null
+++ b/testing/checkpolicy/0001-remove-apple-ifdef.patch
@@ -0,0 +1,16 @@
+--- a/checkpolicy.c
++++ b/checkpolicy.c
+@@ -71,13 +71,11 @@
+ #include <fcntl.h>
+ #include <stdio.h>
+ #include <errno.h>
+ #include <sys/mman.h>
+
+-#ifdef __APPLE__
+ #include <ctype.h>
+-#endif
+
+ #include <sepol/module_to_cil.h>
+ #include <sepol/policydb/policydb.h>
+ #include <sepol/policydb/services.h>
+ #include <sepol/policydb/conditional.h>
diff --git a/testing/checkpolicy/APKBUILD b/testing/checkpolicy/APKBUILD
new file mode 100644
index 0000000000..65caffab0a
--- /dev/null
+++ b/testing/checkpolicy/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tycho Andersen <tycho@docker.com>
+pkgname=checkpolicy
+pkgver=2.6
+pkgrel=0
+pkgdesc="SELinux policy checker"
+url="http://www.selinuxproject.org"
+arch="all"
+license="GPL2"
+makedepends="libsepol-dev bison flex-dev"
+subpackages="$pkgname-doc"
+source="https://github.com/SELinuxProject/selinux/archive/checkpolicy-$pkgver.tar.gz
+ 0001-remove-apple-ifdef.patch
+ "
+builddir="$srcdir/selinux-checkpolicy-$pkgver/checkpolicy"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="24f617d1fbc17422ede258836cf7f90cf6ef1f018fe3848bcafd69a768b47e7fa2de31452f3ad76b15de4ef962b5d5c7313a42b718b9d905b096b2361f1a9b12 checkpolicy-2.6.tar.gz
+9392c01f4fe73ccf7bed865b9721b8f0d9d76068f68ec03af41e07fae7aede6d53627ca001585b171f973d2d83b4f2f65465de78597eba3b5e576b9c7aa903a7 0001-remove-apple-ifdef.patch"