aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cntlm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-05-31 11:36:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-31 11:36:37 +0000
commit4bda782ed5286fe600a9b52e55bca0618c8fe6f7 (patch)
tree82334c3260182e74a9770c5dcfb8b223bce566c9 /testing/cntlm
parentb83414a37ae782cd07ba66c11633c023de41f836 (diff)
downloadaports-4bda782ed5286fe600a9b52e55bca0618c8fe6f7.tar.bz2
aports-4bda782ed5286fe600a9b52e55bca0618c8fe6f7.tar.xz
testing/cntlm: ressurect from unmaintained
ref #7351
Diffstat (limited to 'testing/cntlm')
-rw-r--r--testing/cntlm/APKBUILD51
-rw-r--r--testing/cntlm/cntlm.initd39
2 files changed, 90 insertions, 0 deletions
diff --git a/testing/cntlm/APKBUILD b/testing/cntlm/APKBUILD
new file mode 100644
index 0000000000..854f2a4782
--- /dev/null
+++ b/testing/cntlm/APKBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=cntlm
+pkgver=0.92.3
+pkgrel=1
+pkgdesc="NTLM Session Response / NTLMv2 authenticating HTTP proxy"
+url="http://cntlm.sourceforge.net/"
+arch="all"
+license="GPLv2+"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/cntlm/cntlm/cntlm%20$pkgver/cntlm-$pkgver.tar.gz
+ cntlm.initd
+ "
+_builddir="$srcdir"/cntlm-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+}
+
+md5sums="0d7fcfbfbef0546306b896be246caa88 cntlm-0.92.3.tar.gz
+9837b30f345c621b8d60db59a772a65c cntlm.initd"
+sha256sums="9c3ad10924d43f7248df9ecd33cbc033afbd7ea8d9545de0d68a2782fed76298 cntlm-0.92.3.tar.gz
+082cd3fce99222166261485830b2a565008a3e006b2ba82a4504422a047d60e2 cntlm.initd"
+sha512sums="64f97524f1c807dd3bad3f6c1cffb9d3315c720b086336b7379c8c6380c7c483a9c810b40e7e5ea463387476cd718a8e5fcbc1c7103d7128dfc72a8607e6fd39 cntlm-0.92.3.tar.gz
+d77aaad9cf95c5631032d023fb05964fbee2febe6ca5a1f93c95936d1fc9f53321d62fa69ef8bab8045d271109b0bfc0896628859c7a6bf9e76cad3efa5d4fee cntlm.initd"
diff --git a/testing/cntlm/cntlm.initd b/testing/cntlm/cntlm.initd
new file mode 100644
index 0000000000..449d1f2361
--- /dev/null
+++ b/testing/cntlm/cntlm.initd
@@ -0,0 +1,39 @@
+#!/sbin/openrc-run
+
+description="Authenticating HTTP accelerator for NTLM secured proxies"
+
+depend() {
+ need localmount net
+ use dns logger
+ after bootmisc firewall
+}
+
+checkconfig() {
+ CNTLM_INSTANCE=${SVCNAME#*.}
+ if [ -n "${CNTLM_INSTANCE}" -a "${SVCNAME}" != "cntlm" ]; then
+ CNTLM_CONF="/etc/cntlm.d/${CNTLM_INSTANCE}.conf"
+ CNTLM_PID="/var/run/cntlm.${CNTLM_INSTANCE}.pid"
+ else
+ CNTLM_CONF="/etc/cntlm.conf"
+ CNTLM_PID="/var/run/cntlm.pid"
+ fi
+ if [ ! -e ${CNTLM_CONF} ]; then
+ eerror "You will need an ${CNTLM_CONF} first"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --exec /usr/sbin/cntlm --pidfile "${CNTLM_PID}" \
+ -- -c "${CNTLM_CONF}" -P "${CNTLM_PID}"
+ eend $?
+}
+
+stop() {
+ checkconfig || return 1
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec /usr/sbin/cntlm --pidfile "${CNTLM_PID}"
+ eend $?
+}