aboutsummaryrefslogtreecommitdiffstats
path: root/testing/colormake
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2017-06-02 11:08:29 +0200
committerShiz <hi@shiz.me>2017-06-02 11:31:31 +0200
commit0820fb9e29f197c7606d3caabec7b51268a78de8 (patch)
treec62a0d1dd6e53de191f7c354d1a67afcbc328122 /testing/colormake
parenteac3cd24245d20afd46fac0f1bdc39c1e9ba2e10 (diff)
downloadaports-0820fb9e29f197c7606d3caabec7b51268a78de8.tar.bz2
aports-0820fb9e29f197c7606d3caabec7b51268a78de8.tar.xz
testing/colormake: add check()
No check in upstream, adds a simple ./colormake --version as check()
Diffstat (limited to 'testing/colormake')
-rw-r--r--testing/colormake/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/testing/colormake/APKBUILD b/testing/colormake/APKBUILD
index 751120aac7..59d714ac28 100644
--- a/testing/colormake/APKBUILD
+++ b/testing/colormake/APKBUILD
@@ -7,19 +7,21 @@ pkgdesc="A simple wrapper around make to colorize the output"
url="http://bre.klaki.net/programs/colormake"
arch="noarch"
license="GPL2+"
-depends="perl"
-options="!check"
+checkdepends="make"
+depends="bash perl"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/pagekite/Colormake/archive/$pkgver.tar.gz"
builddir="$srcdir/Colormake-$pkgver"
-build() {
+check() {
cd "$builddir"
- sed -i 's|colormake.pl|/usr/share/colormake/&|' colormake
+ PATH=.:${PATH} ./colormake --version
}
package() {
cd "$builddir"
+ # sed must be done after check()
+ sed -i 's|colormake.pl|/usr/share/colormake/&|' colormake
install -Dm0755 colormake "$pkgdir"/usr/bin/colormake
install -Dm0755 colormake.pl "$pkgdir"/usr/share/colormake/colormake.pl
install -Dm0644 colormake.1 "$pkgdir"/usr/share/man/man1/colormake.1