aboutsummaryrefslogtreecommitdiffstats
path: root/testing/criu
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-11-18 08:57:21 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2016-11-18 08:57:26 +0100
commit57ebbf1ab4a4c69dea9a6141648cc70fa05b85e0 (patch)
tree19350d2a87fc3801800f83fb89f73b72d90ad077 /testing/criu
parent6d313818485c5a347a67b61a403700ad5a7834fc (diff)
downloadaports-57ebbf1ab4a4c69dea9a6141648cc70fa05b85e0.tar.bz2
aports-57ebbf1ab4a4c69dea9a6141648cc70fa05b85e0.tar.xz
testing/criu: upgrade to 2.8 and cleanup
Diffstat (limited to 'testing/criu')
-rw-r--r--testing/criu/APKBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/testing/criu/APKBUILD b/testing/criu/APKBUILD
index fe7ae46159..ad04c0369c 100644
--- a/testing/criu/APKBUILD
+++ b/testing/criu/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=criu
-pkgver=2.6
+pkgver=2.8
pkgrel=0
pkgdesc="A Checkpoint/Restore utility for Linux in Userspace"
url="http://criu.org"
arch="all"
license="GPL2"
-makedepends="xmlto asciidoc python protobuf-c-dev protobuf-dev libaio-dev libnl3-dev \
- py-protobuf libcap-dev"
-subpackages="$pkgname-dev $pkgname-doc py-$pkgname:_py"
+makedepends="xmlto asciidoc python protobuf-c-dev protobuf-dev libaio-dev libnl3-dev
+ py-protobuf libcap-dev"
+subpackages="$pkgname-dev $pkgname-doc py-$pkgname:_py:noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/xemul/$pkgname/archive/v$pkgver.tar.gz
unknown-type__uid_t.patch
fix-wait.h.patch
@@ -17,33 +17,32 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/xemul/$pkgname/archive/v$pkg
builddir="$srcdir/"$pkgname-$pkgver
build() {
- cd "$builddir" # https://wiki.gentoo.org/wiki/Project:Quality_Assurance/As-needed
+ cd "$builddir"
+ # https://wiki.gentoo.org/wiki/Project:Quality_Assurance/As-needed
export LDFLAGS=$(echo $LDFLAGS |sed 's|-Wl,--as-needed||')
- make || return 1
-# make test || return 1
+ make
}
package() {
cd "$builddir"
make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/libexec/criu/scripts/systemd-autofs-restart.sh || return 1
- for dir in $(find "$pkgdir"/usr/libexec -type d | sort -r); do rmdir $dir || return 1; done
+ find "$pkgdir"/usr/libexec -type d -delete
}
_py() {
pkgdesc="Python bindings for Criu"
depends="python"
- arch="noarch"
mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/ || return 1
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-md5sums="f31216c3769536b0daa04bd71df7e351 criu-2.6.tar.gz
+md5sums="cef406bb915e92ed842c819d6c744195 criu-2.8.tar.gz
94e0c93b6c82d4e9e26a64da6ed4e6d9 unknown-type__uid_t.patch
50a7fa53171d082bdbc2558d5c0cec9e fix-wait.h.patch"
-sha256sums="e4e0ba905593a5b8b1112b789dd2a04e9d183dfc0f0ac36a59e74381c2c0ec54 criu-2.6.tar.gz
+sha256sums="a254a7d1f41814cf57b25715e64f43070f91bf3d7651e634d3e4a3369c29844b criu-2.8.tar.gz
703ce29be3324b92b2118482da17656bd691d844f787e50ec9a3c379827d81ad unknown-type__uid_t.patch
75f2d549250d4eddb17db92c8c2c63cbe125d27058b51665184c5536bf3a783e fix-wait.h.patch"
-sha512sums="5fca78f6a14e338ae58a6f565dfef34f97267e9dbea12fe32237e75cd00603809ae9f03eac24a1dec3166ea99bb20742055a6d0dc2643a8276fbdfdeda19eeb5 criu-2.6.tar.gz
+sha512sums="4b7e11f7de6e41a153a650030a3495204eff693679535ff431fb8ba2ab8de48f693c9cb1e4d42fddb4f2291208f17435f6a77fa8dd3ed5f30f19d913bb5af263 criu-2.8.tar.gz
a9abac887a453b5265f18ebd75432eecfd1a1be18b43078651163789ebea76f2d155ff4574bc43d9d025d6bd3360a053aee0a73bf5dcc319294e8138ee514019 unknown-type__uid_t.patch
c35ae61b7bd20b2205949213d5a54a5a31e7aab6eaed5f9afa00dad6ab0fa8007cae25f4cda89957b5535f3073487a854169b09eda3ee48ab6d9af8ce055d991 fix-wait.h.patch"