aboutsummaryrefslogtreecommitdiffstats
path: root/testing/fossil
diff options
context:
space:
mode:
authorPaul Onyschuk <blink@bojary.koba.pl>2011-05-31 19:02:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-03 08:18:07 +0000
commite27110c83f571d8df06cf11b3e5ed628f2dfa294 (patch)
tree0e727aa9d9b7680c4a9d8d2d3cf0892feac8350a /testing/fossil
parentb518c2f3ce7d1e33a4a1ba176eefbf67aaa6a093 (diff)
downloadaports-e27110c83f571d8df06cf11b3e5ed628f2dfa294.tar.bz2
aports-e27110c83f571d8df06cf11b3e5ed628f2dfa294.tar.xz
testing/fossil: new aport
Diffstat (limited to 'testing/fossil')
-rw-r--r--testing/fossil/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/fossil/APKBUILD b/testing/fossil/APKBUILD
new file mode 100644
index 0000000000..e2cd387848
--- /dev/null
+++ b/testing/fossil/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Paul Onyschuk <blink@bojary.koba.pl>
+# Maintainer:
+pkgname=fossil
+pkgver=20110528185122
+pkgrel=0
+pkgdesc="Simple, high-reliability, distributed software configuration management"
+url="http://www.fossil-scm.org"
+arch="all"
+license="BSD"
+depends="openssl zlib"
+makedepends="openssl-dev zlib-dev"
+source="$url/download/$pkgname-src-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-src-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm 755 $pkgname "$pkgdir"/usr/bin/$pkgname || return 1
+}
+
+md5sums="3b5573ce42d9874e5184712d8522bc95 fossil-src-20110528185122.tar.gz"