aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gnome-shell/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 14:16:11 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 16:28:46 +0000
commitabd9671ba0c051612e679b13500c514a74b9a956 (patch)
treed69071701009c8bed444635eee642281c76de3cf /testing/gnome-shell/APKBUILD
parent203114e05ec49106dc16337b13fbc7af97feb421 (diff)
downloadaports-abd9671ba0c051612e679b13500c514a74b9a956.tar.bz2
aports-abd9671ba0c051612e679b13500c514a74b9a956.tar.xz
testing/gnome-shell: upgrade to 3.26.0, added check(), modernize APKBUILD
Diffstat (limited to 'testing/gnome-shell/APKBUILD')
-rw-r--r--testing/gnome-shell/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/testing/gnome-shell/APKBUILD b/testing/gnome-shell/APKBUILD
index fb8e394cc6..9286ddc26e 100644
--- a/testing/gnome-shell/APKBUILD
+++ b/testing/gnome-shell/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=gnome-shell
-pkgver=3.24.2
-pkgrel=1
+pkgver=3.26.0
+pkgrel=0
pkgdesc="GNOME shell"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch="all !aarch64 !armhf"
@@ -23,13 +23,12 @@ makedepends="gnome-desktop-dev
evolution-data-server-dev evolution-dev
python3
-
+ meson
itstool
libxml2-utils"
subpackages="$pkgname-lang $pkgname-dbg"
-install=""
-source="http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.24/gnome-shell-$pkgver.tar.xz"
-builddir="$srcdir/gnome-shell-$pkgver"
+source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -44,9 +43,14 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="28fc399e48d45f3eb1625c854651bf63628bfdf0ec32528c7eef11dabaee1aa5731ae3e863c640b0c31961f9346276c284e7415e9f82284c0f2dd87fbd8fc860 gnome-shell-3.24.2.tar.xz"
+sha512sums="3da595226f6c95dbdb934eedf99c83515de516a2a86fa4cb2964520e3b411a0ac450a93743443db94e553681628ece0633dd5196c17e950292bcbd3050c736a7 gnome-shell-3.26.0.tar.xz"