aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-mux
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 09:00:28 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 09:00:28 +0000
commitcc62417daffa2fbcfe7b65c592501cf1dc2e22a0 (patch)
treeae9596632971b13513c173aa51228de8188d8515 /testing/go-mux
parentafeceac8bea618a79480841a484aae91a98284e1 (diff)
downloadaports-cc62417daffa2fbcfe7b65c592501cf1dc2e22a0.tar.bz2
aports-cc62417daffa2fbcfe7b65c592501cf1dc2e22a0.tar.xz
testing/go-mux: upgrade to 1.6.0
Modernize APKBUILD, update license, disable check(), take maintainership
Diffstat (limited to 'testing/go-mux')
-rw-r--r--testing/go-mux/APKBUILD36
1 files changed, 13 insertions, 23 deletions
diff --git a/testing/go-mux/APKBUILD b/testing/go-mux/APKBUILD
index 1b4c4e46c2..38fffbdfd9 100644
--- a/testing/go-mux/APKBUILD
+++ b/testing/go-mux/APKBUILD
@@ -1,45 +1,35 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=go-mux
-_realname=mux
+_pkgname=mux
_vendor=gorilla
-pkgver=1.1
+pkgver=1.6.0
pkgrel=0
pkgdesc="A powerful URL router and dispatcher for golang"
url="http://www.gorillatoolkit.org"
arch="noarch"
-license="Custom"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=
+license="BSD-3-Clause"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/gorilla/$_realname/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/$_realname-$pkgver
-
-prepare() {
- cd "$builddir"
-}
+options="!check" # no testsuite
+source="$pkgname-$pkgver.tar.gz::https://github.com/gorilla/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
+ return 0
}
package() {
cd "$builddir"
mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
- "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
for file in \
LICENSE \
- README.md \
+ README.* \
COPYRIGHT \
AUTHORS \
; do \
- test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$_realname
+ test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$_pkgname
done
- mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+ mv *.go "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
}
-md5sums="6e2b50af81690dd20f08259317ed45c7 go-mux-1.1.tar.gz"
-sha256sums="66c6990df41605fd1de54a1d6d4e6460d4c4c00f0ace9fc82f6c2c68b13fb8aa go-mux-1.1.tar.gz"
-sha512sums="8610d69ab2cd58e02084f1860a5de152b27d530962a11f4a7fab1b15d404fb3fa3b159df4178853d1b226a5d2a47171bb7121de49ba4dc18d5d3bc6d5c1f26ac go-mux-1.1.tar.gz"
+sha512sums="da34df7ec9533c65da72c82724888babdea5ac0f54a3d69fe1f3a8976db28c5a65fac3772582199fb3100ee636f71a12dd6c9b25c248b8fab250225f8c60f34a go-mux-1.6.0.tar.gz"