aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-uuid
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 10:52:41 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-12 10:52:41 +0000
commit7b8cb840465101c00b2ef6ce1334fbe146454919 (patch)
treef77fb2f69d7ffdfbe0d4104636208665b6a94e10 /testing/go-uuid
parent4c4e7a262b750696715b2316561e988c2adf41aa (diff)
downloadaports-7b8cb840465101c00b2ef6ce1334fbe146454919.tar.bz2
aports-7b8cb840465101c00b2ef6ce1334fbe146454919.tar.xz
testing/go-uuid: modernize APKBUILD, update license, disable check()
Take maintainership
Diffstat (limited to 'testing/go-uuid')
-rw-r--r--testing/go-uuid/APKBUILD38
1 files changed, 14 insertions, 24 deletions
diff --git a/testing/go-uuid/APKBUILD b/testing/go-uuid/APKBUILD
index a392981698..282ac89d64 100644
--- a/testing/go-uuid/APKBUILD
+++ b/testing/go-uuid/APKBUILD
@@ -1,45 +1,35 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=go-uuid
-_realname=go.uuid
-pkgver=1.1.0
+_pkgname=go.uuid
+pkgver=1.2.0
pkgrel=0
-pkgdesc=" UUID package for Go"
-url="https://github.com/satori/$_realname"
+pkgdesc="UUID package for Go"
+url="https://github.com/satori/$_pkgname"
arch="noarch"
-license="Custom"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=
+license="MIT"
subpackages="$pkgname-doc"
_vendor="satori"
-source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_realname/archive/v$pkgver.tar.gz"
-builddir="$srcdir"/$_realname-$pkgver
-
-prepare() {
- cd "$builddir"
-}
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_vendor/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
+ return 0
}
package() {
cd "$builddir"
mkdir -p "$pkgdir"/usr/share/doc/$_vendor/$pkgname \
- "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname
+ "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
for file in \
LICENSE \
- README.md \
+ README.* \
COPYRIGHT \
AUTHORS \
; do \
test -e $file && mv $file "$pkgdir"/usr/share/doc/$_vendor/$pkgname
done
- mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_realname || return 1
+ mv * "$pkgdir"/usr/lib/go/src/github.com/$_vendor/$_pkgname
}
-md5sums="d0cd15432cf30fae3d6594f3f0839171 go-uuid-1.1.0.tar.gz"
-sha256sums="a9509d7769794df7d26964d5dc297c8ad7349f8ff5585f294e8fddd1c6abe946 go-uuid-1.1.0.tar.gz"
-sha512sums="2da3454ddd147d9e18c7405cdd95271c6d56aaac3085e0e9bc50106d224a28e3bd693bf1eb7e6109a0839a738cd068dddf3caa749e1bdf027627a65f3b747e1d go-uuid-1.1.0.tar.gz"
+sha512sums="ed1089397ec2bd4f8852ec3d0888a48be73f183e1b2e582c74fcc6363f605bbcf7dcbb26142eeffe23026b72ec85dbe6af52ae1e16234258dd9a2d7a6bdc8dae go-uuid-1.2.0.tar.gz"