aboutsummaryrefslogtreecommitdiffstats
path: root/testing/greenbone-security-assistant/001-fortify-source.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 15:06:20 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-11-30 15:06:20 +0000
commit4e607422f2655b3da9497bf6f252b02fa76283d5 (patch)
tree3027d8d1068de082994df20b4258b652ffebddee /testing/greenbone-security-assistant/001-fortify-source.patch
parent141a8ec1385110248c99ba9222bff6e289dad9f4 (diff)
downloadaports-4e607422f2655b3da9497bf6f252b02fa76283d5.tar.bz2
aports-4e607422f2655b3da9497bf6f252b02fa76283d5.tar.xz
testing/greenbone-security-assistant: new aport
Diffstat (limited to 'testing/greenbone-security-assistant/001-fortify-source.patch')
-rw-r--r--testing/greenbone-security-assistant/001-fortify-source.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/testing/greenbone-security-assistant/001-fortify-source.patch b/testing/greenbone-security-assistant/001-fortify-source.patch
new file mode 100644
index 0000000000..afd1af231d
--- /dev/null
+++ b/testing/greenbone-security-assistant/001-fortify-source.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 549833c..a4e7882 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -487,7 +487,7 @@ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/zones.xml
+
+ ## Program
+
+-set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
++set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
+
+ set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -Wall")