aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hidrd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-04 14:14:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-04 14:14:26 +0000
commitd2a8f5bc6e03f1a71185d263370179eaf61102f0 (patch)
tree1523e77d0ff915c562455588007174a26ce58b90 /testing/hidrd
parent9adcf14ddbfdf8a99b47c82513f0257e05a9913f (diff)
downloadaports-d2a8f5bc6e03f1a71185d263370179eaf61102f0.tar.bz2
aports-d2a8f5bc6e03f1a71185d263370179eaf61102f0.tar.xz
testing/hidrd: new aport
HID report descriptor I/O library and conversion tool https://github.com/DIGImend/hidrd
Diffstat (limited to 'testing/hidrd')
-rw-r--r--testing/hidrd/APKBUILD41
-rw-r--r--testing/hidrd/musl-fix-headers.patch12
2 files changed, 53 insertions, 0 deletions
diff --git a/testing/hidrd/APKBUILD b/testing/hidrd/APKBUILD
new file mode 100644
index 0000000000..b6ea4b2916
--- /dev/null
+++ b/testing/hidrd/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hidrd
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="HID report descriptor I/O library and conversion tool"
+url="https://github.com/DIGImend/hidrd"
+arch="all"
+license="GPL-2.0"
+depends=""
+makedepends="musl-obstack-dev m4"
+install=""
+subpackages="$pkgname-dev"
+source="https://github.com/DIGImend/hidrd/releases/download/$pkgver/hidrd-$pkgver.tar.gz
+ musl-fix-headers.patch"
+builddir="$srcdir/hidrd-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ LIBS=-lobstack \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b2121904f7327766b17ade631d6862cea6c0010cee060620150480f70ed0fb00cebf06cd2c6623ab509e1579abe2a835920d8c5290c21bca4143b15c6a814e22 hidrd-0.2.0.tar.gz
+43651cd05b01867eeba370786c6db06b6d7d31713607ee34c1529377463dcf12c8af4efbcbe9ee27018deef030e63ad324a364d2701fde5c369edd7206427ee1 musl-fix-headers.patch"
diff --git a/testing/hidrd/musl-fix-headers.patch b/testing/hidrd/musl-fix-headers.patch
new file mode 100644
index 0000000000..d6de2e3b71
--- /dev/null
+++ b/testing/hidrd/musl-fix-headers.patch
@@ -0,0 +1,12 @@
+diff --git a/lib/util/ttbl.c b/lib/util/ttbl.c
+index 12bf5c7..f98ebed 100644
+--- a/lib/util/ttbl.c
++++ b/lib/util/ttbl.c
+@@ -28,6 +28,7 @@
+ #include <stdint.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include "hidrd/util/buf.h"
+ #include "hidrd/util/ttbl.h"
+