aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hplip
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2016-12-23 00:03:08 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:44:03 +0200
commitabfd2e4f147bb0a0717b9568f205d583ab60ebce (patch)
tree775fd3983d90babae6265989755d12b3448af5a1 /testing/hplip
parente066e04622295bb27963c3f1892dede0374300fb (diff)
downloadaports-abfd2e4f147bb0a0717b9568f205d583ab60ebce.tar.bz2
aports-abfd2e4f147bb0a0717b9568f205d583ab60ebce.tar.xz
testing/hplip: upgrade to 3.16.11, enable scanners
add scanner (sane backend) support, close #6520 make lite install (libs and drivers only) remove fax-, hal-, systemd-, dbus- related trash remove python dependency move libs to subpackage
Diffstat (limited to 'testing/hplip')
-rw-r--r--testing/hplip/APKBUILD62
-rw-r--r--testing/hplip/disable_upgrade.patch14
2 files changed, 37 insertions, 39 deletions
diff --git a/testing/hplip/APKBUILD b/testing/hplip/APKBUILD
index fd18dd4c5f..3c20e2bc0e 100644
--- a/testing/hplip/APKBUILD
+++ b/testing/hplip/APKBUILD
@@ -1,48 +1,60 @@
# Maintainer:
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
# Contributor: Timo Teräs <timo.teras@iki.fi>
-
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=hplip
-pkgver=3.16.10
+pkgver=3.16.11
pkgrel=0
-pkgdesc="Drivers for HP printers"
+pkgdesc="Drivers for HP printers and scanners"
arch=all
url="http://hplipopensource.com"
license="GPL"
-depends="python py-dbus"
-makedepends="libjpeg-turbo-dev net-snmp-dev cups-dev libusb-dev python-dev"
-subpackages="$pkgname-doc"
+depends=""
+makedepends="libjpeg-turbo-dev net-snmp-dev cups-dev libusb-dev sane-dev"
+subpackages="$pkgname-doc $pkgname-libs sane-backend-hpaio:sane"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- fix-includes.patch
- disable_upgrade.patch"
+ fix-includes.patch"
+builddir="$srcdir"/$pkgname-$pkgver
-builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
./configure --prefix=/usr \
- --disable-qt4 \
- --disable-scan-build \
+ --with-docdir=/usr/share/doc/$pkgname \
+ --enable-lite-build \
+ --disable-doc-build \
+ --disable-gui-build \
--disable-fax-build \
--disable-dbus-build \
+ --enable-cups-drv-install \
--enable-cups-ppd-install \
- --enable-foomatic-ppd-install \
- --enable-foomatic-drv-install \
|| return 1
make || return 1
}
package() {
- make -j1 -C "$builddir" DESTDIR="$pkgdir" install || return 1
- cd "$pkgdir"
- rm -rf etc/sane.d etc/xdg usr/share/hal etc/init.d etc/udev
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ rm -fr "$pkgdir"/usr/bin \
+ "$pkgdir"/etc/udev \
+ "$pkgdir"/etc/sane.d \
+ "$pkgdir"/usr/share/hal \
+ "$pkgdir"/usr/lib/systemd \
+ "$pkgdir"/usr/lib/cups/filter/pstotiff
+}
+
+sane() {
+ depends="sane"
+ pkgdesc="SANE backend for HP multi-function peripherals"
+ provides="$pkgname-sane"
+ mkdir -p "$subpkgdir"/usr/lib \
+ "$subpkgdir"/etc/sane.d/dll.d
+ mv "$pkgdir"/usr/lib/sane "$subpkgdir"/usr/lib
+ echo "hpaio" > "$subpkgdir"/etc/sane.d/dll.d/hpaio
}
-md5sums="dd3bf0ecd410e6961abd86407b7f802f hplip-3.16.10.tar.gz
-a9cd9a64bc4e1ba14ef221efdcb0d940 fix-includes.patch
-65bddd5951bd2d12a26bbf7b51bcab27 disable_upgrade.patch"
-sha256sums="45b44e0334f76069511b0b2a40885a12d055013bc95a62250de5d1abc10dee84 hplip-3.16.10.tar.gz
-9a1d8b509d7bcacb03895529e3c6c83704ea784444bf0deae75ac59feb9e32b2 fix-includes.patch
-b3f8d91a07216e6aad4dbfdb79ae19496b03c29f56444059b9b93a32c86ceb8e disable_upgrade.patch"
-sha512sums="2aa8cdd7ec0aa042f4c159f4db6bf80e0cc4ffd30f060814d44fcce2f2800dc0195c26ccc6f8d10dc9c62b3fcbc0befcf68f3ad6a5a81f63ab6a26a25686bbad hplip-3.16.10.tar.gz
-173f0c2bbf0daefc717282bf125d3fd94b3914da0754078c45b58b09ab841672aae9238ca8fc0448486a871e40fc50f960da17c1e07ad3f04053d217ed634498 fix-includes.patch
-57e14c581e82a0dd44344524dc4eb4d845843cf0775b60475541cabfb9d67a4fdab501be3977f8ca9888fbbee4d0392e6068c788e7a85cf4c1add5848be21ae7 disable_upgrade.patch"
+md5sums="7d187c3142ba323a3021767d333ad9f4 hplip-3.16.11.tar.gz
+a9cd9a64bc4e1ba14ef221efdcb0d940 fix-includes.patch"
+sha256sums="f6e20cacb4891e4e60fc5de2213a10f8d0c68840f9b511aa38cfca0cb29f9b24 hplip-3.16.11.tar.gz
+9a1d8b509d7bcacb03895529e3c6c83704ea784444bf0deae75ac59feb9e32b2 fix-includes.patch"
+sha512sums="c59d50adbcc930543b828a81f055653e140987ac9d0b5232cfe6f657078565a3f2a0c96fc13f0dbb575916d59ca76a3447da7cf023bafef900375d4e53d9e180 hplip-3.16.11.tar.gz
+173f0c2bbf0daefc717282bf125d3fd94b3914da0754078c45b58b09ab841672aae9238ca8fc0448486a871e40fc50f960da17c1e07ad3f04053d217ed634498 fix-includes.patch"
diff --git a/testing/hplip/disable_upgrade.patch b/testing/hplip/disable_upgrade.patch
deleted file mode 100644
index f95b4dfe4b..0000000000
--- a/testing/hplip/disable_upgrade.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/upgrade.py 2013-10-31 12:46:54.000000000 +0100
-+++ b/upgrade.py 2013-12-04 14:58:03.000000000 +0100
-@@ -134,6 +134,11 @@ except getopt.GetoptError, e:
- if os.getenv("HPLIP_DEBUG"):
- log.set_level('debug')
-
-+
-+log.error("HPLIP upgrade is disabled by Alpine Linux for security reasons, see https://bugs.archlinux.org/task/38083")
-+clean_exit(1)
-+
-+
- for o, a in opts:
- if o in ('-h', '--help'):
- usage()