aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hvtools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-07-15 12:39:59 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-07-18 16:38:50 +0200
commit2ca6099b98c497478b4fffdeda0ca7455ea9d7df (patch)
tree6cf70b4e2133dd1ad7e26b85cd77f6d20d693a6e /testing/hvtools
parentdb9ddd00b7534cf165637a4175e2c2648580f5ac (diff)
downloadaports-2ca6099b98c497478b4fffdeda0ca7455ea9d7df.tar.bz2
aports-2ca6099b98c497478b4fffdeda0ca7455ea9d7df.tar.xz
testing/hvtools: upgrade to 4.4.15 and add init.d scripts
Diffstat (limited to 'testing/hvtools')
-rw-r--r--testing/hvtools/APKBUILD25
-rw-r--r--testing/hvtools/hv_fcopy_daemon.initd10
-rw-r--r--testing/hvtools/hv_kvp_daemon.initd15
-rw-r--r--testing/hvtools/hv_vss_daemon.initd10
4 files changed, 56 insertions, 4 deletions
diff --git a/testing/hvtools/APKBUILD b/testing/hvtools/APKBUILD
index d488b27ea0..a0382e9f25 100644
--- a/testing/hvtools/APKBUILD
+++ b/testing/hvtools/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hvtools
-pkgver=4.4.6
+pkgver=4.4.15
_kernver=${pkgver%.*}
pkgrel=0
pkgdesc="Hyper-v tools"
@@ -12,6 +12,9 @@ makedepends="$depends_dev linux-headers"
subpackages=""
source="http://ftp.kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
http://ftp.kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
+ hv_kvp_daemon.initd
+ hv_vss_daemon.initd
+ hv_fcopy_daemon.initd
"
builddir="$srcdir"/linux-${_kernver}
@@ -35,11 +38,25 @@ package() {
install -t "$pkgdir"/usr/bin \
hv_kvp_daemon hv_vss_daemon hv_fcopy_daemon \
|| return 1
+ for i in $source; do
+ case $i in
+ *.initd) install -Dm755 "$srcdir"/$i "$pkgdir"/etc/init.d/${i%.*} || return 1;;
+ esac
+ done
}
md5sums="9a78fa2eb6c68ca5a40ed5af08142599 linux-4.4.tar.xz
-d48f09bf61f2500d70f839e190dc7c5a patch-4.4.6.xz"
+12786f8aef0ad2f87cbf95a68f34cb56 patch-4.4.15.xz
+e32a3d8ffa326952b38bea9c8bb99c18 hv_kvp_daemon.initd
+b0a970aa2050ecbe107848fcc6a3165a hv_vss_daemon.initd
+db859f35172b9994196ddbc3526a6385 hv_fcopy_daemon.initd"
sha256sums="401d7c8fef594999a460d10c72c5a94e9c2e1022f16795ec51746b0d165418b2 linux-4.4.tar.xz
-efea93ff30955d445344a83c36678fa8e64111219eeafea2a41fd4ee11f79d68 patch-4.4.6.xz"
+69fcb928e4958f87fb134d0f6acf98072655b5572dd3497c3a0844882f261bf8 patch-4.4.15.xz
+023797a0d0cff285e3f08b0be17d4cb66db166c278ba0f49dfaa533ea9f4dfd8 hv_kvp_daemon.initd
+1e009a2d54a8aa7750f605da01ed3fb72323640bc07597ad567d295c8af76244 hv_vss_daemon.initd
+7fa3a03e938c09dd30abdc767253f722fc586ba82bcdf6ef458be05eae539acf hv_fcopy_daemon.initd"
sha512sums="13c8459933a8b80608e226a1398e3d1848352ace84bcfb7e6a4a33cb230bbe1ab719d4b58e067283df91ce5311be6d2d595fc8c19e2ae6ecc652499415614b3e linux-4.4.tar.xz
-73da057476eb31d818eed4b66c883f5ceec65f18ec8ea60d64e48334c7681af4ed4cf7eb8684481f705446a59fd124de9449d22e28805bc9617b6608ecec491d patch-4.4.6.xz"
+1522839ac4f1330db34618a20712e42ae85d4961b2d2a699723c2675f065f52b07127bb96b33944ee519448027dcd402a31503d748debb12f05fb0f2896b3d73 patch-4.4.15.xz
+25590c4253da6ad248875b19e222fbc283216c4557eebfb8e471a2ed3330be19d3bd4b1bc6d7c2aa4ca7a64aa565c80887cbad711fa8e3ec477a7b56ba014166 hv_kvp_daemon.initd
+afcdbc83b9c01cb2fd1d6f1844925f0860a8b3352f50e2db2e7ebf8843b338d2aea8f5b1586ef12009022249da11aa9f6cba4fbe438ff59f3a734e2d425306ce hv_vss_daemon.initd
+4f327330eb755ef04d9475a03aab625a0690efcbb8c6f614b333189aa998391d57b3ddae8baec0cfbc3b280ceca1e9271c9cfc5f68c3becb37db0fc85935422a hv_fcopy_daemon.initd"
diff --git a/testing/hvtools/hv_fcopy_daemon.initd b/testing/hvtools/hv_fcopy_daemon.initd
new file mode 100644
index 0000000000..eda7463ab0
--- /dev/null
+++ b/testing/hvtools/hv_fcopy_daemon.initd
@@ -0,0 +1,10 @@
+#!/sbin/openrc-run
+
+name="Hyper-V daemon: hv_fcopy_daemon"
+command=/usr/bin/hv_fcopy_daemon
+
+depend() {
+ use clock logger
+ need localmount
+}
+
diff --git a/testing/hvtools/hv_kvp_daemon.initd b/testing/hvtools/hv_kvp_daemon.initd
new file mode 100644
index 0000000000..71f31238f7
--- /dev/null
+++ b/testing/hvtools/hv_kvp_daemon.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+
+name="Hyper-V daemon: hv_kvp_daemon"
+command=/usr/bin/hv_kvp_daemon
+
+depend() {
+ use clock logger
+ need localmount net
+}
+
+start_pre() {
+ # Delete the existing store
+ rm -rf /var/lib/hyperv
+}
+
diff --git a/testing/hvtools/hv_vss_daemon.initd b/testing/hvtools/hv_vss_daemon.initd
new file mode 100644
index 0000000000..049171b0a5
--- /dev/null
+++ b/testing/hvtools/hv_vss_daemon.initd
@@ -0,0 +1,10 @@
+#!/sbin/openrc-run
+
+name="Hyper-V daemon: hv_vss_daemon"
+command=/usr/bin/hv_vss_daemon
+
+depend() {
+ use clock logger
+ need dev
+}
+