aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hylafaxplus
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-16 12:08:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-16 12:08:55 +0000
commit234bc57e60982d09a11caf752e31bb1c57522ca9 (patch)
tree131957c21a878b310475b79afbc0cc1af4a49f69 /testing/hylafaxplus
parent818d6e0c2336b8c682c96e933acbf8a1d6e7a343 (diff)
downloadaports-234bc57e60982d09a11caf752e31bb1c57522ca9.tar.bz2
aports-234bc57e60982d09a11caf752e31bb1c57522ca9.tar.xz
testing/hylafaxplus: fix parallel build
Diffstat (limited to 'testing/hylafaxplus')
-rw-r--r--testing/hylafaxplus/APKBUILD8
-rw-r--r--testing/hylafaxplus/fix-parallel-build.patch13
2 files changed, 17 insertions, 4 deletions
diff --git a/testing/hylafaxplus/APKBUILD b/testing/hylafaxplus/APKBUILD
index 9ab9cf9c0a..c6a05c4e5c 100644
--- a/testing/hylafaxplus/APKBUILD
+++ b/testing/hylafaxplus/APKBUILD
@@ -17,6 +17,7 @@ source="https://downloads.sourceforge.net/hylafax/${_pkgname}-${pkgver}.tar.gz
$pkgname.initd
$pkgname.confd
musl-reg-startend.patch
+ fix-parallel-build.patch
"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -50,9 +51,7 @@ build() {
--with-DSO=auto \
--with-PATH_EGETTY=/bin/false \
--with-PATH_VGETTY=/bin/false
-
- # parallel build breaks libfaxutil dso building
- make -j1
+ make
}
package(){
@@ -96,4 +95,5 @@ package(){
sha512sums="67ac84df2619db7fb88cd7ad3af4beff9918b2481fc8edf7cc7574941161dd7aa6186cfc49c6cdb2a1f073f6cbf2f2a4ed084ca70ebe288bf7cd8e752cd56b2d hylafax-5.5.9.tar.gz
3862cefcd26092000e4489c097537e5e0e2ae1f7c2a7a16b1e933b3bb78d136b6d8a65fb712ae245dd8ca881900408d0d9788bd2e0b859a9569fc6f4ede8cc7c hylafaxplus.initd
3c07726cc9d7351dceb80a46354c6626e54b033b0f434c1db01db2a3b3ab5e9084d551dd23cae3ab40806f27aa5fa0a5b70c43a6b7802356871c0b343baa2376 hylafaxplus.confd
-be6e9f9d86340c63919aaf158c92d541904f2567b78ad2742a041f86333549b66715f108012de9a968b78bcdada8f94aa98320cda69724bf518ff3efbdf00f32 musl-reg-startend.patch"
+be6e9f9d86340c63919aaf158c92d541904f2567b78ad2742a041f86333549b66715f108012de9a968b78bcdada8f94aa98320cda69724bf518ff3efbdf00f32 musl-reg-startend.patch
+219f1ffcfa3bc40ffbacd015cc22aef06c936ff1c1427d0119c1da6ca1f587e0ac12af9c01042f081c77f9cb6c83375f5f44a675d65435fd8e5cc112bf138e1a fix-parallel-build.patch"
diff --git a/testing/hylafaxplus/fix-parallel-build.patch b/testing/hylafaxplus/fix-parallel-build.patch
new file mode 100644
index 0000000000..0d2dc48918
--- /dev/null
+++ b/testing/hylafaxplus/fix-parallel-build.patch
@@ -0,0 +1,13 @@
+diff --git a/util/Makefile.LINUXdso b/util/Makefile.LINUXdso
+index c39a146..d3fd0b7 100644
+--- a/util/Makefile.LINUXdso
++++ b/util/Makefile.LINUXdso
+@@ -30,7 +30,7 @@
+ # DSO-specific rules for the util directory.
+ #
+
+-libfaxutil.${DSO}: ${OBJECTS}
++${LIBUTIL} libfaxutil.${DSO}: ${OBJECTS}
+ ${C++} ${DSOOPTS} -o libfaxutil.${DSO} ${OBJECTS} \
+ ${DSODELAY} ${LIBTIFF} ${DSODELAY} ${LIBZ} ${DSODELAY} ${LIBREGEX}
+