aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hylafaxplus
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-03-20 09:21:22 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-03-20 09:21:57 +0000
commitf3f372fd8cb068082a0202fedb2aaa7374f32282 (patch)
tree5c3ad4d8855ae571c5e92aaf4fd38441b39f9a7d /testing/hylafaxplus
parent3dc06e6bd067a31c8e9c7c2fed46640e3821181d (diff)
downloadaports-f3f372fd8cb068082a0202fedb2aaa7374f32282.tar.bz2
aports-f3f372fd8cb068082a0202fedb2aaa7374f32282.tar.xz
testing/hylafaxplus: revert commit fixing parallel build since is not complete
Diffstat (limited to 'testing/hylafaxplus')
-rw-r--r--testing/hylafaxplus/APKBUILD12
-rw-r--r--testing/hylafaxplus/fix-parallel-build.patch13
2 files changed, 4 insertions, 21 deletions
diff --git a/testing/hylafaxplus/APKBUILD b/testing/hylafaxplus/APKBUILD
index 96988e4cf0..3ba833d547 100644
--- a/testing/hylafaxplus/APKBUILD
+++ b/testing/hylafaxplus/APKBUILD
@@ -18,7 +18,6 @@ source="https://downloads.sourceforge.net/hylafax/${_pkgname}-${pkgver}.tar.gz
$pkgname.initd
$pkgname.confd
musl-reg-startend.patch
- fix-parallel-build.patch
"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -27,10 +26,6 @@ build() {
# the configure script does not handle ccache or distcc
export CC=gcc
export CXX=g++
- case "$CARCH" in
- ppc64le) par_options="-j1"
- ;;
- esac
./configure \
--nointeractive \
--disable-pam \
@@ -52,7 +47,9 @@ build() {
--with-DSO=auto \
--with-PATH_EGETTY=/bin/false \
--with-PATH_VGETTY=/bin/false
- make $par_options
+
+ # parallel build breaks libfaxutil dso building
+ make -j1
}
package(){
@@ -96,5 +93,4 @@ package(){
sha512sums="67ac84df2619db7fb88cd7ad3af4beff9918b2481fc8edf7cc7574941161dd7aa6186cfc49c6cdb2a1f073f6cbf2f2a4ed084ca70ebe288bf7cd8e752cd56b2d hylafax-5.5.9.tar.gz
3862cefcd26092000e4489c097537e5e0e2ae1f7c2a7a16b1e933b3bb78d136b6d8a65fb712ae245dd8ca881900408d0d9788bd2e0b859a9569fc6f4ede8cc7c hylafaxplus.initd
a2117eddc8f0ff70a23a90f2001dcb88c5bddee46ffa021d6d1701cc5cfc3bcb0362ead2b1b1ce2b288992728053c5947466d08916649f45e7dfb1876576e50f hylafaxplus.confd
-be6e9f9d86340c63919aaf158c92d541904f2567b78ad2742a041f86333549b66715f108012de9a968b78bcdada8f94aa98320cda69724bf518ff3efbdf00f32 musl-reg-startend.patch
-219f1ffcfa3bc40ffbacd015cc22aef06c936ff1c1427d0119c1da6ca1f587e0ac12af9c01042f081c77f9cb6c83375f5f44a675d65435fd8e5cc112bf138e1a fix-parallel-build.patch"
+be6e9f9d86340c63919aaf158c92d541904f2567b78ad2742a041f86333549b66715f108012de9a968b78bcdada8f94aa98320cda69724bf518ff3efbdf00f32 musl-reg-startend.patch"
diff --git a/testing/hylafaxplus/fix-parallel-build.patch b/testing/hylafaxplus/fix-parallel-build.patch
deleted file mode 100644
index 0d2dc48918..0000000000
--- a/testing/hylafaxplus/fix-parallel-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/util/Makefile.LINUXdso b/util/Makefile.LINUXdso
-index c39a146..d3fd0b7 100644
---- a/util/Makefile.LINUXdso
-+++ b/util/Makefile.LINUXdso
-@@ -30,7 +30,7 @@
- # DSO-specific rules for the util directory.
- #
-
--libfaxutil.${DSO}: ${OBJECTS}
-+${LIBUTIL} libfaxutil.${DSO}: ${OBJECTS}
- ${C++} ${DSOOPTS} -o libfaxutil.${DSO} ${OBJECTS} \
- ${DSODELAY} ${LIBTIFF} ${DSODELAY} ${LIBZ} ${DSODELAY} ${LIBREGEX}
-