aboutsummaryrefslogtreecommitdiffstats
path: root/testing/icmake
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-05-06 02:49:29 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-05-06 14:55:37 +0200
commit0728c2c6b4728d08d4c0fed741ef5b99c35194bd (patch)
tree703648e8fb2fa69d0ad99bfde2a4c781b0784a39 /testing/icmake
parent143b6dfe7e521eaa10d7a257087630092bf005fa (diff)
downloadaports-0728c2c6b4728d08d4c0fed741ef5b99c35194bd.tar.bz2
aports-0728c2c6b4728d08d4c0fed741ef5b99c35194bd.tar.xz
testing/icmake: new aport
https://fbb-git.github.io/icmake/ a make utility using a C-like grammar
Diffstat (limited to 'testing/icmake')
-rw-r--r--testing/icmake/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/icmake/APKBUILD b/testing/icmake/APKBUILD
new file mode 100644
index 0000000000..c2e226763e
--- /dev/null
+++ b/testing/icmake/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Shiz <hi@shiz.me>
+# Maintainer: Shiz <hi@shiz.me>
+pkgname=icmake
+pkgver=9.02.02
+pkgrel=0
+pkgdesc="Make utility using a C-like grammar"
+url="https://fbb-git.github.io/icmake/"
+arch="all"
+license="GPL3+"
+makedepends="bash"
+subpackages="$pkgname-doc"
+source="icmake-$pkgver.tar.gz::https://github.com/fbb-git/icmake/archive/$pkgver.tar.gz"
+builddir="$srcdir/icmake-$pkgver/icmake"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ sed -i '/^#define DOCDOCDIR/d' INSTALL.im
+ echo '#define DOCDOCDIR "usr/share/doc/icmake"' >> INSTALL.im
+}
+
+build() {
+ cd "$builddir"
+ ./icm_prepare /
+ ./icm_bootstrap x
+}
+
+check() {
+ cd "$builddir"
+ ./tmp/usr/bin/icmake --version
+ ./tmp/usr/bin/icmbuild --version
+}
+
+package() {
+ cd "$builddir"
+ ./icm_install strip all "$pkgdir"
+}
+
+sha512sums="7d62569d21224f4584fe6901690a53fa82882e5690ef296cd0fcd770bc19503ea5a5469a7b6eebc8b6719606630e24477801c3c5752c70efdb74a6f6d30bddb9 icmake-9.02.02.tar.gz"