aboutsummaryrefslogtreecommitdiffstats
path: root/testing/imake
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-05 11:09:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-05 11:09:01 +0000
commit7541bbd6fa664e4d67718aa380c5585e99803827 (patch)
treecbe5263c762a1ea97736685685b38da95d9805f2 /testing/imake
parent663f10baf4dcd8433d77ceb2607c622b26be6754 (diff)
downloadaports-7541bbd6fa664e4d67718aa380c5585e99803827.tar.bz2
aports-7541bbd6fa664e4d67718aa380c5585e99803827.tar.xz
testing/imake: do not install in /usr/local
Diffstat (limited to 'testing/imake')
-rw-r--r--testing/imake/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/testing/imake/APKBUILD b/testing/imake/APKBUILD
index 64704c637a..cf5117efd5 100644
--- a/testing/imake/APKBUILD
+++ b/testing/imake/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=imake
pkgver=1.0.4
-pkgrel=0
+pkgrel=1
pkgdesc="X Windows make utility"
url="http://www.x.org"
arch="all"
@@ -10,7 +10,7 @@ depends=
depends_dev=
makedepends="xproto util-macros $depends_dev"
install=""
-#subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-doc"
source="http://ftp.x.org/pub/individual/util/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -26,14 +26,13 @@ prepare() {
build() {
cd "$_builddir"
- ./configure || make || return 1
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
}
package() {
- echo "PACKAGE stage"
- echo "pkgdir = $pkgdir"
cd "$_builddir"
- pwd
make DESTDIR="$pkgdir" install || return 1
}