aboutsummaryrefslogtreecommitdiffstats
path: root/testing/keepassxc
diff options
context:
space:
mode:
authorOrson Teodoro <orsonteodoro@hotmail.com>2018-02-08 10:51:20 -0800
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-02 10:01:16 +0000
commit976e26631a85f339105c218390cd676de3f823e8 (patch)
tree017948d94c920953e25a48c9c3322fa372ad9a18 /testing/keepassxc
parent91658af81c15044507c7c28c444871745bedab17 (diff)
downloadaports-976e26631a85f339105c218390cd676de3f823e8.tar.bz2
aports-976e26631a85f339105c218390cd676de3f823e8.tar.xz
testing/keepassxc: new aport
This is the forked version of KeePassX with additional features and continued development. Additional details can be found at https://keepassxc.org/ .
Diffstat (limited to 'testing/keepassxc')
-rw-r--r--testing/keepassxc/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/keepassxc/APKBUILD b/testing/keepassxc/APKBUILD
new file mode 100644
index 0000000000..488b9471dd
--- /dev/null
+++ b/testing/keepassxc/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Contributor: August Klein <amatcoder@gmail.com>
+# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
+
+pkgname=keepassxc
+pkgver=2.2.4
+pkgrel=0
+pkgdesc="KeePassXC is a cross-platform community-driven port of the Windows \
+application Keepass Password Safe."
+url="https://keepassxc.org/"
+arch="all"
+license="GPL-3.0 BSD-3-Clause CC0-1.0 LGPL-2.0-only LGPL-2.1-only \
+ LGPL-3.0-or-later Nokia-Qt-exception-1.1 MIT BSL-1.0"
+depends="icu-libs"
+makedepends="cmake qt5-qtbase-dev qt5-qttools-dev libxtst-dev \
+ qt5-x11extras-dev libgcrypt-dev libgpg-error-dev argon2-dev zlib-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/keepassxreboot/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_BUILD_TYPE=Release .
+ make
+}
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -d "$pkgdir"/usr/share/doc/$pkgname/ \
+ "$pkgdir"/usr/share/licenses/$pkgname/
+ install -t "$pkgdir"/usr/share/doc/$pkgname/ \
+ "$builddir"/CHANGELOG "$builddir"/README.md
+ install -t "$pkgdir"/usr/share/licenses/$pkgname/ \
+ "$builddir"/LICENSE.NOKIA-LGPL-EXCEPTION \
+ "$builddir"/LICENSE.CC0 "$builddir"/COPYING
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+sha512sums="f3308138d63b65a8b384a52f4723507be921d7bbf19031724886fcd12266bf2683326f5531c8f665b0e98ff63cd97251694199ef748191e59a5a8cceb3710025 keepassxc-2.2.4.tar.gz"