aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kubernetes/fix-support-for-ppc64le.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-01-12 16:26:46 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-01-12 16:27:09 +0000
commitf24402c59aee6fcdd4383258e544135f2c19039b (patch)
tree41c25b0ffdaf6fe6a932e399c393f6709855dc10 /testing/kubernetes/fix-support-for-ppc64le.patch
parentc91bba7beb3a5cb3204fa59656532a80def51c39 (diff)
downloadaports-f24402c59aee6fcdd4383258e544135f2c19039b.tar.bz2
aports-f24402c59aee6fcdd4383258e544135f2c19039b.tar.xz
testing/kubernetes: moved from unmaintained, fixed build, upgrade to 1.5.2
Diffstat (limited to 'testing/kubernetes/fix-support-for-ppc64le.patch')
-rw-r--r--testing/kubernetes/fix-support-for-ppc64le.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/kubernetes/fix-support-for-ppc64le.patch b/testing/kubernetes/fix-support-for-ppc64le.patch
new file mode 100644
index 0000000000..820c44c030
--- /dev/null
+++ b/testing/kubernetes/fix-support-for-ppc64le.patch
@@ -0,0 +1,53 @@
+From 2bdaa87387d7d02afb52ccc0fee1f0f017ce5ecc Mon Sep 17 00:00:00 2001
+From: Jan Chaloupka <jchaloup@redhat.com>
+Date: Thu, 5 Jan 2017 12:21:39 +0100
+Subject: [PATCH] fix support for ppc64le
+
+---
+ src/k8s.io/kubernetes/Makefile | 2 +-
+ src/k8s.io/kubernetes/hack/lib/init.sh | 2 +-
+ src/k8s.io/kubernetes/hack/lib/util.sh | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index bce3533..e2f2bf9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -39,7 +39,7 @@ MAKEFLAGS += --no-builtin-rules
+ # Constants used throughout.
+ .EXPORT_ALL_VARIABLES:
+ OUT_DIR ?= _output
+-BIN_DIR := $(OUT_DIR)/bin
++BIN_DIR := $(OUT_DIR)/local/go/bin
+ PRJ_SRC_PATH := k8s.io/kubernetes
+ GENERATED_FILE_PREFIX := zz_generated.
+
+diff --git a/hack/lib/init.sh b/hack/lib/init.sh
+index 0a601ac..68029e2 100644
+--- a/hack/lib/init.sh
++++ b/hack/lib/init.sh
+@@ -42,7 +42,7 @@ source "${KUBE_ROOT}/hack/lib/version.sh"
+ source "${KUBE_ROOT}/hack/lib/golang.sh"
+ source "${KUBE_ROOT}/hack/lib/etcd.sh"
+
+-KUBE_OUTPUT_HOSTBIN="/usr/bin"
++KUBE_OUTPUT_HOSTBIN="${KUBE_OUTPUT_BINPATH}/go/bin"
+
+ # list of all available group versions. This should be used when generated code
+ # or when starting an API server that you want to have everything.
+diff --git a/hack/lib/util.sh b/hack/lib/util.sh
+index ada6e34..5911b65 100755
+--- a/hack/lib/util.sh
++++ b/hack/lib/util.sh
+@@ -168,7 +168,7 @@ kube::util::find-binary-for-platform() {
+ local -r lookfor="$1"
+ local -r platform="$2"
+ local -r locations=(
+- "${KUBE_ROOT}/_output/bin/${lookfor}"
++ "${KUBE_ROOT}/_output/local/go/bin/${lookfor}"
+ "${KUBE_ROOT}/_output/dockerized/bin/${platform}/${lookfor}"
+ "${KUBE_ROOT}/_output/local/bin/${platform}/${lookfor}"
+ "${KUBE_ROOT}/platforms/${platform}/${lookfor}"
+--
+2.7.4
+