aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libbytesize
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-25 08:21:41 +0000
committerAndy Postnikov <apostnikov@gmail.com>2018-04-26 05:11:34 +0300
commitbaee05d0e3079214df35e0819f4d657b9604734d (patch)
treeec10fa5cf33e7be965385755169f1f742034944b /testing/libbytesize
parentd952ee9176b97ab9acfe1dea2c2b79914ba720de (diff)
downloadaports-baee05d0e3079214df35e0819f4d657b9604734d.tar.bz2
aports-baee05d0e3079214df35e0819f4d657b9604734d.tar.xz
testing/libbytesize: add subpackage for python bindings
Diffstat (limited to 'testing/libbytesize')
-rw-r--r--testing/libbytesize/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/testing/libbytesize/APKBUILD b/testing/libbytesize/APKBUILD
index 08f2002395..c5f1c53c1c 100644
--- a/testing/libbytesize/APKBUILD
+++ b/testing/libbytesize/APKBUILD
@@ -8,7 +8,7 @@ url="https://github.com/rhinstaller/libbytesize"
arch="all"
license="LGPL"
makedepends="pcre-dev mpfr-dev gmp-dev gettext-dev python3"
-subpackages="$pkgname-dev $pkgname-lang"
+subpackages="$pkgname-dev $pkgname-lang py-$pkgname:py"
source="https://github.com/storaged-project/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/"$pkgname-$pkgver
@@ -23,4 +23,11 @@ package() {
make DESTDIR="$pkgdir" install
}
+py() {
+ pkgdesc="Python bindings for $pkgname"
+
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
sha512sums="a8e5b5d59d0a97ae52a2c0f437c4d7fd8afc8249762be99027e3beeadc6c54ad52a09c1d30e66466b99496fcf3419fa799d0fcccf61c0661b3e9cff48d0054af libbytesize-1.3.tar.gz"