aboutsummaryrefslogtreecommitdiffstats
path: root/testing/liblo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-05 10:04:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-05 10:04:05 +0000
commitbd6894d8a49cc6ac491c25635655e7c6e47290ac (patch)
treecf3bca016ef5e25e9a0607f6ba702b8c86993947 /testing/liblo
parentf08d5081d923805de4db493c424dc73b402d481b (diff)
downloadaports-bd6894d8a49cc6ac491c25635655e7c6e47290ac.tar.bz2
aports-bd6894d8a49cc6ac491c25635655e7c6e47290ac.tar.xz
testing/liblo: new aport
Open Sound Control library http://liblo.sourceforge.net
Diffstat (limited to 'testing/liblo')
-rw-r--r--testing/liblo/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/liblo/APKBUILD b/testing/liblo/APKBUILD
new file mode 100644
index 0000000000..a7c9c18722
--- /dev/null
+++ b/testing/liblo/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liblo
+pkgver=0.26
+pkgrel=0
+pkgdesc="Open Sound Control library"
+url="http://liblo.sourceforge.net"
+arch="all"
+license="LGPLv2+"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev"
+source="http://download.sf.net/sourceforge/liblo/liblo-$pkgver.tar.gz"
+
+_builddir="$srcdir"/liblo-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --enable-ipv6 \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="5351de14262560e15e7f23865293b16f liblo-0.26.tar.gz"