aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libmpack
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-23 22:37:51 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-23 22:39:28 +0100
commit789614a621041df107469594892aa5ac0232600c (patch)
treecf0c123a425918c6a2b8d74a18d44a7c4bb8a678 /testing/libmpack
parent316a1c11d3a4e60bbc7f1516c45ae36b1105ef92 (diff)
downloadaports-789614a621041df107469594892aa5ac0232600c.tar.bz2
aports-789614a621041df107469594892aa5ac0232600c.tar.xz
testing/libmpack: new aport
https://github.com/libmpack/libmpack Simple implementation of msgpack in C
Diffstat (limited to 'testing/libmpack')
-rw-r--r--testing/libmpack/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/libmpack/APKBUILD b/testing/libmpack/APKBUILD
new file mode 100644
index 0000000000..d850a7d41c
--- /dev/null
+++ b/testing/libmpack/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=libmpack
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="Simple implementation of msgpack in C"
+url="https://github.com/libmpack/libmpack"
+arch="all"
+license="MIT"
+makedepends="libtool"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/libmpack/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="6e30edafcacfb580b410bc6749ed7fe8f18b3be0cb98959339853e77bc3ec0cda6df08a0f1f22768cfc773458a2ea6bcef4f0421eea55cf56c58981d13711a04 libmpack-1.0.5.tar.gz"