aboutsummaryrefslogtreecommitdiffstats
path: root/testing/librtas
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-02-09 17:27:32 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-02-12 18:29:20 +0100
commit0ffae5b3534d68fe9dab84746947ab186cece2b4 (patch)
treefacefe009805ad991c3e4f80300e4fa825b30246 /testing/librtas
parented291e6970b3d2346311bfdcb4fe395bccf1a35d (diff)
downloadaports-0ffae5b3534d68fe9dab84746947ab186cece2b4.tar.bz2
aports-0ffae5b3534d68fe9dab84746947ab186cece2b4.tar.xz
testing/librtas: new aport
librtas is a library that is required to access RTAS (Run-Time Abstraction Services). Most of the ppc64le packages depends on this package for hardware access.
Diffstat (limited to 'testing/librtas')
-rw-r--r--testing/librtas/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/librtas/APKBUILD b/testing/librtas/APKBUILD
new file mode 100644
index 0000000000..ad0cdecdbf
--- /dev/null
+++ b/testing/librtas/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Breno Leitao <breno.leitao@gmail.com>
+pkgname=librtas
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="Librtas provides a set of libraries that access Run-Time Abstraction Services (RTAS)"
+url="https://github.com/nfont/librtas"
+arch="ppc64le"
+license="LGPL"
+depends=""
+makedepends="autoconf automake libtool linux-headers"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nfont/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ ./autogen.sh || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="3a3ee6c9aecef7721b5045bdd14daaa8 librtas-2.0.1.tar.gz"
+sha256sums="a79fd9cdb2f03e7401027fb80a07f14e29b86cc2d363126d527b211fea85d025 librtas-2.0.1.tar.gz"
+sha512sums="922465aa08bc0de49ae259a2655081eb8f91dcc213475b6cac6c4740279433011699a3b50cc23941bb3275f85deec2ffefc2bf1faae51a4baf8baa067b4d6a4d librtas-2.0.1.tar.gz"