aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libselinux/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-03-16 10:01:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-03-16 10:06:43 +0000
commit5fabd625a8532b6b8502072e6b3671c1e139caee (patch)
tree95c6027d970131698998e305cab2e48a7a85437a /testing/libselinux/APKBUILD
parent43e3c0978a948fe4e1112c7b68574a09f777a3d3 (diff)
downloadaports-5fabd625a8532b6b8502072e6b3671c1e139caee.tar.bz2
aports-5fabd625a8532b6b8502072e6b3671c1e139caee.tar.xz
testing/libselinux: really fix ln issue
we really need coreutils for ln --relative because SHLIBDIR=/lib and LIBDIR=/usr/lib. Instead of trying to do something smart we just pull in GNU coreutils.
Diffstat (limited to 'testing/libselinux/APKBUILD')
-rw-r--r--testing/libselinux/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/testing/libselinux/APKBUILD b/testing/libselinux/APKBUILD
index ff0cb1feb6..b58af9ac4e 100644
--- a/testing/libselinux/APKBUILD
+++ b/testing/libselinux/APKBUILD
@@ -1,18 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libselinux
pkgver=2.6
-pkgrel=0
+pkgrel=1
pkgdesc="SELinux library and simple utilities"
url="https://github.com/SELinuxProject/selinux/wiki"
arch="all"
license="Public Domain"
depends=""
depends_dev=""
-makedepends="$depends_dev pcre-dev linux-headers libsepol-dev fts-dev"
+# we need coreutils for ln --relative
+makedepends="$depends_dev pcre-dev linux-headers libsepol-dev fts-dev coreutils"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/libselinux-$pkgver.tar.gz
- symlink.patch
"
builddir="$srcdir/libselinux-$pkgver"
@@ -33,5 +33,4 @@ utils() {
mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/
}
-sha512sums="906e1bf98c669862ab4f4e883d511db8d739a5763dc857c9405ad3cc6c70766a482853d07134698a1a98257a8632cc756d0549a7640c2915d051714f502ff14b libselinux-2.6.tar.gz
-3a4cefdcdd32df7430b38c961e9e20cebf1bdea9fa2fdba9680269426c07b6766d0f4e2f6a0b938c5d6d90110f71729413fe00877740ef592f96c706657b21f1 symlink.patch"
+sha512sums="906e1bf98c669862ab4f4e883d511db8d739a5763dc857c9405ad3cc6c70766a482853d07134698a1a98257a8632cc756d0549a7640c2915d051714f502ff14b libselinux-2.6.tar.gz"