aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libubox
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-09-19 14:34:28 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-09-19 14:34:28 +0000
commitfede70d348437c5afc54707a859a9c0e364b6540 (patch)
tree40881fed6c253bbebceaa8a6a58646784297b551 /testing/libubox
parent6a4b99cb963051d02ba11f055d29455064717ff3 (diff)
downloadaports-fede70d348437c5afc54707a859a9c0e364b6540.tar.bz2
aports-fede70d348437c5afc54707a859a9c0e364b6540.tar.xz
Revert "testing/libubox: new aport"
Diffstat (limited to 'testing/libubox')
-rw-r--r--testing/libubox/APKBUILD54
-rw-r--r--testing/libubox/includes.patch11
-rw-r--r--testing/libubox/json-pkgconf-detect.patch11
3 files changed, 0 insertions, 76 deletions
diff --git a/testing/libubox/APKBUILD b/testing/libubox/APKBUILD
deleted file mode 100644
index 73bacf8eca..0000000000
--- a/testing/libubox/APKBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-# Maintainer:
-pkgname=libubox
-pkgver=0_git20150919
-pkgrel=0
-pkgdesc="C utility functions for OpenWrt"
-url="https://github.com/xfguo/libubox"
-arch="all"
-license="GPL"
-depends=
-depends_dev=
-makedepends="$depends_dev autoconf cmake json-c-dev"
-subpackages="$pkgname-dev"
-install=
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- json-pkgconf-detect.patch
- includes.patch
- "
-giturl="https://github.com/xfguo/libubox.git"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- cmake CMakeLists.txt -DBUILD_LUA=OFF -DCMAKE_INSTALL_PREFIX=/usr || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
-}
-
-md5sums="4cce46a9b75ff1ac335989276231f6ad libubox-0_git20150919.tar.gz
-eb218033a9c32ea192e5b7b7950588e2 json-pkgconf-detect.patch
-5abfaee650e28f4e1211633a84d88d47 includes.patch"
-sha256sums="03677f7fb78f4076522525ecc8ddb616e81a85e132f93f5fc744f156802ba7e2 libubox-0_git20150919.tar.gz
-891e69fe1d5d5ca9f8a70cc73c4a066d6f11437372cd1f61de6e9f0d5da1eafe json-pkgconf-detect.patch
-0bc997c6d7355c30f43f3168caaad5f8b7e9b58b4e909d6b0c9dbe5c86d153e3 includes.patch"
-sha512sums="7c8185cd4a876343849b092919b8be891a8c1de26bee29f61a5473c3fdf000de2709fecbe4b3de041c429e223c1902af24eb503e8a66c1ab4471f23a56b04d3e libubox-0_git20150919.tar.gz
-a7ad77529f9976d9e991f72009c851743d8ff7435d2a831bb14fe929834ae59b5afbfb158c5faca4c4a6edd7076bb533875813d95e3672f065474dc4a63323a2 json-pkgconf-detect.patch
-9db73110f57f33ce08f078cafb7eff4a22905415391d5d7a2bc69651517f714fb042b4a5c7f975f4b0d2e2d1193b593af0910f544309bf7eb70c5d7db4d2c212 includes.patch"
diff --git a/testing/libubox/includes.patch b/testing/libubox/includes.patch
deleted file mode 100644
index 2ba75aaf1b..0000000000
--- a/testing/libubox/includes.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/blobmsg_json.h
-+++ b/blobmsg_json.h
-@@ -19,7 +19,7 @@
- #ifdef JSONC
- #include <json.h>
- #else
-- #include <json/json.h>
-+ #include <json-c/json.h>
- #endif
-
- #include <stdbool.h>
diff --git a/testing/libubox/json-pkgconf-detect.patch b/testing/libubox/json-pkgconf-detect.patch
deleted file mode 100644
index c566fd2b4a..0000000000
--- a/testing/libubox/json-pkgconf-detect.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -13,7 +13,7 @@
- ENDIF()
-
- INCLUDE(FindPkgConfig)
--PKG_CHECK_MODULES(JSONC json-c json)
-+PKG_CHECK_MODULES(JSONC json-c)
- IF(JSONC_FOUND)
- ADD_DEFINITIONS(-DJSONC)
- INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})