aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libva-utils
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2017-07-02 23:22:40 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-07-07 11:07:45 +0000
commit275371db6dff10349b38c8a460469c7505a11246 (patch)
treee0e14747e07157146e5e1a1763e268a6339f4935 /testing/libva-utils
parent718dab76d54eabb6b771488ef17c97f0c1f5e374 (diff)
downloadaports-275371db6dff10349b38c8a460469c7505a11246.tar.bz2
aports-275371db6dff10349b38c8a460469c7505a11246.tar.xz
testing/libva-utils: new aport
https://github.com/01org/libva-utils Intel VA-API Media Applications and Scripts for libva
Diffstat (limited to 'testing/libva-utils')
-rw-r--r--testing/libva-utils/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/libva-utils/APKBUILD b/testing/libva-utils/APKBUILD
new file mode 100644
index 0000000000..8399946b2e
--- /dev/null
+++ b/testing/libva-utils/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Taner Tas <taner76@gmail.com>
+pkgname=libva-utils
+pkgver="1.8.2"
+pkgrel=0
+pkgdesc="Intel VA-API Media Applications and Scripts for libva"
+url="https://github.com/01org/libva-utils"
+arch="all"
+license="custom"
+makedepends="mesa-dev libva-dev autoconf automake libtool"
+source="${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
+options="!check"
+builddir="${srcdir}/${pkgname}-${pkgver}"
+build() {
+ cd "$builddir"
+ ./autogen.sh \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-wayland \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-nls
+ make
+}
+
+check(){
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="e6d1e025d1c27112bf61869fa097a27c81bff9fb1ed5226842f3c7685852b4cc8903b0a29204d3c85bc4513dab9331b327de0f93c9493a411ab15e7e577ce616 libva-utils-1.8.2.tar.gz"