aboutsummaryrefslogtreecommitdiffstats
path: root/testing/micropython
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-11 14:02:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-11 14:04:20 +0000
commit220968092461f20b1a26a159cc4927a1502029f5 (patch)
treea9a957bb316347e140fc3215163a9d4ee2ada007 /testing/micropython
parent3a8a0d9cfd6e2c562b6bc761d585c0a6c2bb2c17 (diff)
downloadaports-220968092461f20b1a26a159cc4927a1502029f5.tar.bz2
aports-220968092461f20b1a26a159cc4927a1502029f5.tar.xz
testing/micropython: disable on x86 and let abuild do strip
It fails to build on x86 with a segfault: MPY modules/upip.py make: *** [../../py/mkrules.mk:114: build/frozen_mpy/upip.mpy] Segmentation fault (core dumped)
Diffstat (limited to 'testing/micropython')
-rw-r--r--testing/micropython/APKBUILD6
-rw-r--r--testing/micropython/micropython-1.9.4-prevent-stripping.patch22
2 files changed, 26 insertions, 2 deletions
diff --git a/testing/micropython/APKBUILD b/testing/micropython/APKBUILD
index 8e62a89473..73a56a796b 100644
--- a/testing/micropython/APKBUILD
+++ b/testing/micropython/APKBUILD
@@ -2,18 +2,19 @@
# Maintainer: Marian <marian.buschsieweke@ovgu.de>
pkgname=micropython
pkgver=1.9.4
-pkgrel=1
+pkgrel=2
pkgdesc="A lean and efficient Python implementation for MCUs and constrained systems"
url="https://www.micropython.org/"
# ../py/persistentcode.c:397:2: error: #error mp_raw_code_save_file not implemented for this platform
-arch="x86 x86_64 armhf armv7 !ppc64le"
+arch="all !ppc64le !s390x !x86"
license="MIT"
depends=""
makedepends="libffi-dev python3"
subpackages="$pkgname-cross"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz
+ micropython-1.9.4-prevent-stripping.patch
0000-unix-mpconfigport.patch
python3.patch
"
@@ -47,5 +48,6 @@ cross() {
}
sha512sums="aae15ed4251e56261e7ce0db6c86727e62d466e43d3867bb080c21653c0ef3cd25b6ee4b0438fab2ecc838b4b73f7b59ae7a851ad20ef6c38b9eb8667a7dc364 micropython-1.9.4.tar.gz
+8f994394f42d7fed5fa35b62c01c37ebea3b487c029d659134a263ef8d65e1ec17bec755fdf57cde2f234969bc4f7f4ab30858562d7f8cdb2bc6cb819ba2ae0d micropython-1.9.4-prevent-stripping.patch
4c1de6a6477453e846998565402c69d1dd716cf692a3bb55aa16b6991722a94d8364c05f0603b981a7dd9e9af577a3f46910a60d501513af547ebbf3ed574711 0000-unix-mpconfigport.patch
8dbdc52e09f70b5eea461257ebc00031ab9d2c91a9bdbd7522e4ffd1eddddcd0dab3a171361e776543abca827a2f5d6ad01b06c10c8635db861bf79bfa065338 python3.patch"
diff --git a/testing/micropython/micropython-1.9.4-prevent-stripping.patch b/testing/micropython/micropython-1.9.4-prevent-stripping.patch
new file mode 100644
index 0000000000..a130b72b61
--- /dev/null
+++ b/testing/micropython/micropython-1.9.4-prevent-stripping.patch
@@ -0,0 +1,22 @@
+--- a/py/mkenv.mk 2017-11-25 09:52:30.921836372 +0000
++++ a/py/mkenv.mk 2017-11-25 09:52:35.257861233 +0000
+@@ -50,7 +50,6 @@
+ LD = $(CROSS_COMPILE)ld
+ OBJCOPY = $(CROSS_COMPILE)objcopy
+ SIZE = $(CROSS_COMPILE)size
+-STRIP = $(CROSS_COMPILE)strip
+ AR = $(CROSS_COMPILE)ar
+ ifeq ($(MICROPY_FORCE_32BIT),1)
+ CC += -m32
+--- a/py/mkrules.mk 2017-11-25 09:53:13.107078063 +0000
++++ a/py/mkrules.mk 2017-11-25 09:53:31.898185592 +0000
+@@ -129,9 +129,6 @@
+ # Do not pass COPT here - it's *C* compiler optimizations. For example,
+ # we may want to compile using Thumb, but link with non-Thumb libc.
+ $(Q)$(CC) -o $@ $^ $(LIB) $(LDFLAGS)
+-ifndef DEBUG
+- $(Q)$(STRIP) $(STRIPFLAGS_EXTRA) $(PROG)
+-endif
+ $(Q)$(SIZE) $$(find $(BUILD) -path "$(BUILD)/build/frozen*.o") $(PROG)
+
+ clean: clean-prog