aboutsummaryrefslogtreecommitdiffstats
path: root/testing/micropython
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2017-08-02 09:24:03 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-03 12:48:14 +0000
commita7b59fce2064665f109a4a2f2c7d80530d58d40b (patch)
treec0dd1c6d242dc9983c3593a95c97f8046030ca32 /testing/micropython
parent9b1159bce3b23f424796b7669be482af4bb0bf96 (diff)
downloadaports-a7b59fce2064665f109a4a2f2c7d80530d58d40b.tar.bz2
aports-a7b59fce2064665f109a4a2f2c7d80530d58d40b.tar.xz
new aport: testing/micropython
A lean and efficient Python implementation for MCUs and constrained systems http://www.micropython.org/
Diffstat (limited to 'testing/micropython')
-rw-r--r--testing/micropython/0000-unix-mpconfigport.patch22
-rw-r--r--testing/micropython/APKBUILD44
2 files changed, 66 insertions, 0 deletions
diff --git a/testing/micropython/0000-unix-mpconfigport.patch b/testing/micropython/0000-unix-mpconfigport.patch
new file mode 100644
index 0000000000..9025694ff2
--- /dev/null
+++ b/testing/micropython/0000-unix-mpconfigport.patch
@@ -0,0 +1,22 @@
+--- old/micropython-1.9.1/unix/mpconfigport.mk
++++ new/micropython-1.9.1/unix/mpconfigport.mk
+@@ -9,7 +9,7 @@
+ MICROPY_USE_READLINE = 1
+
+ # btree module using Berkeley DB 1.xx
+-MICROPY_PY_BTREE = 1
++MICROPY_PY_BTREE = 0
+
+ # _thread module using pthreads
+ MICROPY_PY_THREAD = 1
+@@ -24,8 +24,8 @@
+ MICROPY_PY_FFI = 1
+
+ # ussl module requires axtls
+-MICROPY_PY_USSL = 1
+-MICROPY_SSL_AXTLS = 1
++MICROPY_PY_USSL = 0
++MICROPY_SSL_AXTLS = 0
+ MICROPY_SSL_MBEDTLS = 0
+
+ # jni module requires JVM/JNI
diff --git a/testing/micropython/APKBUILD b/testing/micropython/APKBUILD
new file mode 100644
index 0000000000..fb7b141623
--- /dev/null
+++ b/testing/micropython/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Marian <marian.buschsieweke@ovgu.de>
+# Maintainer: Marian <marian.buschsieweke@ovgu.de>
+pkgname=micropython
+pkgver=1.9.1
+pkgrel=0
+pkgdesc="A lean and efficient Python implementation for MCUs and constrained systems"
+url="http://www.micropython.org/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="libffi-dev python3"
+subpackages=""
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz
+ 0000-unix-mpconfigport.patch"
+builddir="${srcdir}/${pkgname}-${pkgver}/unix"
+
+prepare() {
+ cd "${srcdir}"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$builddir"
+ unset CFLAGS
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "${pkgdir}/usr/bin"
+ install -m755 micropython "${pkgdir}/usr/bin/micropython"
+}
+
+sha512sums="bc0eeb1e6d821034b7157613f2d421df304f2959e9fd62d2886641eba8d74575787861c9ff46fc3bcb9c14c6ad1f698043231801207f946af9b5d302bb253c63 micropython-1.9.1.tar.gz
+926515a76dc856192de79a7c35c390bd533a38a2c163812ce5a3739280ca33881791f3d199922edb2e577ec9ac16265dc4891ad96f6c6eb4e7cf9d5ae8044a32 0000-unix-mpconfigport.patch"