aboutsummaryrefslogtreecommitdiffstats
path: root/testing/micropython
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-12-26 14:48:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-12-26 14:48:43 +0000
commitc460687f37eea27d1d31e6967b328746d16b69b4 (patch)
tree7bbfaffe61d1e5ce614ff3f0ef0ea4531c9cb6cc /testing/micropython
parent492988e0eece238d11f6dcec62a58c52b2740196 (diff)
downloadaports-c460687f37eea27d1d31e6967b328746d16b69b4.tar.bz2
aports-c460687f37eea27d1d31e6967b328746d16b69b4.tar.xz
testing/micropython: fix build with python3
Diffstat (limited to 'testing/micropython')
-rw-r--r--testing/micropython/APKBUILD4
-rw-r--r--testing/micropython/python3.patch50
2 files changed, 53 insertions, 1 deletions
diff --git a/testing/micropython/APKBUILD b/testing/micropython/APKBUILD
index 05bbb3330d..93a5a210fb 100644
--- a/testing/micropython/APKBUILD
+++ b/testing/micropython/APKBUILD
@@ -15,6 +15,7 @@ makedepends="libffi-dev python3"
subpackages="$pkgname-cross"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz
0000-unix-mpconfigport.patch
+ python3.patch
"
builddir="${srcdir}/${pkgname}-${pkgver}"
@@ -46,4 +47,5 @@ cross() {
}
sha512sums="d276dc9a300e400f5fd5742bfc8c641c0af2d3b7f3ae9221b811100d85e9c2a6c6c558775183c58dd4be39a31284c596c0e98c9bb2c8e60ce4cf0d83434d0a47 micropython-1.9.3.tar.gz
-4c1de6a6477453e846998565402c69d1dd716cf692a3bb55aa16b6991722a94d8364c05f0603b981a7dd9e9af577a3f46910a60d501513af547ebbf3ed574711 0000-unix-mpconfigport.patch"
+4c1de6a6477453e846998565402c69d1dd716cf692a3bb55aa16b6991722a94d8364c05f0603b981a7dd9e9af577a3f46910a60d501513af547ebbf3ed574711 0000-unix-mpconfigport.patch
+8dbdc52e09f70b5eea461257ebc00031ab9d2c91a9bdbd7522e4ffd1eddddcd0dab3a171361e776543abca827a2f5d6ad01b06c10c8635db861bf79bfa065338 python3.patch"
diff --git a/testing/micropython/python3.patch b/testing/micropython/python3.patch
new file mode 100644
index 0000000000..13641ea00b
--- /dev/null
+++ b/testing/micropython/python3.patch
@@ -0,0 +1,50 @@
+diff --git a/lib/memzip/make-memzip.py b/lib/memzip/make-memzip.py
+index 9730f5e..3a1f7a5 100755
+--- a/lib/memzip/make-memzip.py
++++ b/lib/memzip/make-memzip.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # Takes a directory of files and zips them up (as uncompressed files).
+ # This then gets converted into a C data structure which can be read
+diff --git a/ports/teensy/make-pins.py b/ports/teensy/make-pins.py
+index 0f6c5f2..5d21d8f 100755
+--- a/ports/teensy/make-pins.py
++++ b/ports/teensy/make-pins.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ """Creates the pin file for the Teensy."""
+
+ from __future__ import print_function
+diff --git a/tools/make-frozen.py b/tools/make-frozen.py
+index 1051b52..06ee7a3 100755
+--- a/tools/make-frozen.py
++++ b/tools/make-frozen.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # Create frozen modules structure for MicroPython.
+ #
+diff --git a/tools/pyboard.py b/tools/pyboard.py
+index 16ee41f..17b7f98 100755
+--- a/tools/pyboard.py
++++ b/tools/pyboard.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ #
+ # This file is part of the MicroPython project, http://micropython.org/
+ #
+diff --git a/tools/pydfu.py b/tools/pydfu.py
+index 8c0220d..55ea952 100755
+--- a/tools/pydfu.py
++++ b/tools/pydfu.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # This file is part of the OpenMV project.
+ # Copyright (c) 2013/2014 Ibrahim Abdelkader <i.abdalkader@gmail.com>
+ # This work is licensed under the MIT license, see the file LICENSE for